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INTRODUCTION
Welcome to the New Horizons training team.

Our goal is to provide you with the best computer training available and we
know exactly what that takes. Our corporate heritage is based in training. In fact,
we use our Student Manuals every day, in classes just like yours, so you can be
confident that the material has been tested and proven to be effective.

If you have any suggestions on how we can improve our products or services,
please contact us.

ABOUT THIS COURSE
basic animations and simple navigation buttons. In this course, you will work
with symbols and instances, create extensive Timelines with independent anima-
tions, build more complex navigation controls, work with sound, and optimize
your movies for viewing by your intended audience.

Course Prerequisites
To ensure your success, you should have familiarity with the Windows operating
system. We also recommend you first take the following New Horizons course or
have equivalent knowledge:

• Flash MX - Level 1

Course Objectives
When you’re done working your way through this book, you’ll be able to:

• Identify the advantages that symbol use has in building a Flash movie, iden-
tify and create the three types of symbols, and manage symbols within a
movie using the Library palette.

• Use scenes to organize content in large complex Timelines, and create frame
labels to mark critical points in your Timeline.

• Add advanced playback controls and interactive elements to a Flash movie
(including remote rollovers and expanding menus), and create preloaders to
ensure smooth playback of larger movie files over slow connections.

• Import sounds into a project, work with sound properties, and edit sounds.

• Test a movie while simulating a slow connection, identify factors that
increase a movie’s size and download time, and publish a movie using many
of Flash’s numerous publishing options.

ABOUT THIS
COURSE

About This Course vii
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COURSE SETUP INFORMATION

Hardware and Software Requirements
To run this course, you will need:

• An Intel Pentium 200 MHz or equivalent processor

• Windows 98 SE, Me, NT4, 2000, or XP.

• 64 MB of random-access memory (128 MB recommended) plus a minimum
of 85 MB of available disk space (64 recommended).

• 1024 x 768, 16-bit (thousands of colors) color display or better

• Either Microsoft Internet Explorer 5.0 and/or Netscape Navigator 4.0 (or
later version).

• Macromedia Flash MX.

• A CD-ROM drive.

Class Requirements
In order for the class to run properly, perform the procedures described below.

1. Install the course data files that come with this book. Open the contents of
the CD-ROM through My Computer, and open the 078_166 folder. Inside
this folder, you will find three separate folders. Copy the Flash Level 2 Data
folder to your C:\ drive. This folder contains all the data material you will
need for the course.

2. The files in the Flash Level 2 Data folder are in read-only format. Therefore,
you should now turn off the read-only option so that the files can be modi-
fied as you work with them. Open the Flash Level 2 Data folder you just
copied to your computer’s hard disk, and choose Edit→Select All to select
all the icons within the folder. Then choose File→Properties. In the Proper-
ties dialog box, uncheck the Read Only checkbox, then click OK. Deselect
the selected icons, and repeat these steps to turn off the read only option for
the contents of each subfolder within the Flash Level 2 Data folder. You are
now ready to begin working with the data.

3. In order to ensure that all needed features of Flash MX will be available for
this course, run a standard install from the software installation CD.

4. The Flash Player plug-in for Web browsers is required to display some of
the content generated during this course in a Web browser. You can down-
load the Flash Player plug-in from the Macromedia Web site. Go to http://
www.macromedia.com, and follow the instructions to download and install
the latest version of the Flash Player.

5. This course specifies the use of the font Arial. If this font is not installed,
the documents the student works on will not display as intended. Make sure
the font Arial is installed on the computer.

6. This course will run most smoothly if your monitor resolution is set to at
least 1024 x 768 pixels per inch.

ABOUT THIS
COURSE
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Using the Provided Stage Data:On the course CD, the Lesson folders in the
Additional Data folder contain all the course documents and data, completed
up to the lesson indicated by the folder name. This allows you to begin at
any lesson in this manual using the correct data that includes all files that
would have been created from previous lessons. It also allows you to begin a
new lesson with fresh, “correct” data, if so desired.

For example, if you would like to begin this manual at Lesson 4, you should
open the Lesson 4 folder in the Additional Data folder in the 078_166 folder
on the course CD, and copy the Flash Level 2 Data folder from the Lesson 4
folder to your computer’s hard disk (first remove or change the name of any
existing Flash Level 2 Data folder on your hard disk). All the files you’ll
need to complete the rest of the course are contained in the new folder.

However, the files in the new Flash Level 2 Data folder are in read-only
format. Therefore, you should now open the Flash Level 2 Data folder you
just copied to your computer’s hard disk, and choose Edit→Select All to
select all the icons within the folder. Then choose File→Properties. In the
Properties dialog box, uncheck the Read Only checkbox, then click OK.
Repeat these steps to turn off the read only option for the contents of each
subfolder within the Flash Level 2 Data folder. The previous steps are only
necessary if you plan to begin this manual at a lesson other than Lesson 1. If
you plan to work straight through the entire manual, then the previous steps
are unnecessary.

HOW TO USE THIS BOOK
You can use this book as a learning guide, a review tool, and a reference.

As a Learning Guide
Each lesson covers one broad topic or set of related topics. Lessons are arranged
in order of increasing proficiency with Flash MX; skills you acquire in one lesson
are used and developed in subsequent lessons. For this reason, you should work
through the lessons in sequence.

We organized each lesson into explanatory topics and step-by-step activities. Top-
ics provide the theory you need to master Flash MX,activities allow you to apply
this theory to practical hands-on examples.

You get to try out each new skill on a specially prepared sample file. This saves
you typing time and allows you to concentrate on the technique at hand. Through
the use of sample files, hands-on activities, illustrations that give you feedback at
crucial steps, and supporting background information, this book provides you
with the foundation and structure to learn Flash MXquickly and easily.

As a Review Tool
Any method of instruction is only as effective as the time and effort you are will-
ing to invest in it. For this reason, we encourage you to spend some time
reviewing the book’s more challenging topics and activities.

ABOUT THIS
COURSE

About This Course ix
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As a Reference
You can use the Concepts sections in this book as a first source for definitions of
terms, background information on given topics, and summaries of procedures.

ABOUT THIS
COURSE
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Symbols and Instances

Overview
In this lesson, you will work with symbols as the building blocks of Flash
projects. You will use the three types of symbols available in Flash, and will
identify which symbol type is the most appropriate for a particular situation.
You will then learn to manage symbols and instances using the Library, and
you will use symbols as the basis for other symbols.

Objectives
To learn to work with symbols and instances effectively, you will:

1A Identify the advantages that symbol use has in building a Flash
movie, and identify the three types of symbols.

You will see how symbols can help you to build projects quickly and
efficiently, and how they save file space. In addition, you will learn the
similarities and differences between graphic, button, and movie clip sym-
bols, and identify when to use each type.

1B Identify the situations where you would use a graphic symbol, and to
convert an object to a graphic symbol.

You will learn when choosing the graphic symbol type is appropriate
when building your movie. In addition, you will use the Convert to Sym-
bol command to convert an existing graphic object to a graphic symbol.

1C Create a movie clip symbol, and identify how it behaves in the main
movie Timeline.

You will create a movie clip symbol to build an animation that is inde-
pendent of the main movie Timeline, and you will combine multiple
movie clip symbols to create a more complex animation.

1D Create button symbols using static and animated image states.

You will create button symbols using static images. You will also create
buttons containing animated image states using independent animations
within movie clip symbols.

1E Create and manage symbols within a movie.

You will create instances from symbols, use the Library to manage sym-
bols, and combine symbols into more complex symbols.

Data Files
Water Scene.fla
Spiral.fla
Preloader.fla

Lesson Time
2 hours

LESSON

1

Lesson 1: Symbols and Instances 1
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Topic 1A
What is a Symbol?
When you draw a simple or complex object in Flash using Flash’s drawing tools,
that object is more or less decorative in nature. It appears within your Flash
project, but you can’t do much with it. In order to add motion to an object, or to
have it act as an interactive element within the movie, that object needs to be a
symbol.

There are several distinct differences between symbols and standard objects in a
Flash movie. First, a symbol does not interact with other shapes when it is on the
same layer. So, when symbols on the same layer overlap with other objects or
symbols, they do not merge or cut into other objects.

Second, symbols can be animated. In order to add motion to an object, that object
needs to be a symbol. Remember that you can’t perform a shape tween (morph)
between one symbol and another. However, in order to perform a motion tween,
you must use a symbol.

Finally, symbols are the building blocks for your project. You can use a single
symbol multiple times in a movie without adding significantly to the movie’s
size. A movie with one symbol used three times will have a smaller file size that
a movie containing an original object and two duplicates of the original object. In
addition, you can combine symbols together when building more complex
symbols. For example, you can use a graphic symbol’s shape as the basis for one
or several of the button states in a button symbol. The more you use symbols, the
smaller your files will be, and the easier it is to make quick changes to your
content.

Types of Symbols
There are three types of symbols in Flash: graphic symbols, movie clip symbols,
and button symbols. Each type of symbol is optimized for certain uses.

Graphic Symbols
Graphic symbolshave their own separate Timeline, similar to the main movie
Timeline. Just like the regular movie Timeline, a graphic symbol’s Timeline can
include multiple layers.

There are several important things to remember about graphic symbols. First,
graphic symbols cannot contain button symbols or sounds. In addition, they can-
not be made to be interactive. Finally, a graphic symbol’s Timeline is tied to the
main Timeline. If the main movie stops playing, the graphic symbol will also
stop playing. Also, if there are not enough frames in the main Timeline for the
graphic symbol’s Timeline to completely play, the graphic symbol’s animation
will not complete. For these reasons, graphic symbols are best used for static
graphics that you want to animate in the main Timeline, or for simple animations
that you want to have playing within the context of the main movie.

symbol:
A “building block” of Flash

content. Symbols are the
master objects within a Flash

movie. The three types are
graphic, movie clip, and

button symbols.

graphic symbol:
A symbol best used for static

images and animations that
are dependent on the main

movie Timeline.
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Movie Clip Symbols
Movie clip symbolsallow you to create independent animations within the main
movie Timeline. If the main movie stops playing, the movie clip symbol’s anima-
tion does not have to necessarily stop. Therefore, you can do a lot of things you
can’t do with a graphic symbol. For example, you can use a movie clip symbol
to create a looping animation within the main Timeline. Additionally, you can use
a movie clip symbol to create an animation within a button. Movie clip symbols
can contain both buttons and sounds, and you can control their playback from the
main Timeline.

Button Symbols
Button symbolsallow you to create elements in your movie that let viewers inter-
act with the movie using the mouse. A button symbol’s Timeline is different than
the graphic or movie clip symbol’s Timeline. It only consists of four frames, one
for each state of the button (up, over, down, and hit).

While button symbols are certainly used for traditional buttons in the movie, you
can create interactive controls that do not resemble traditional buttons at all. For
example, you can use button symbols to create animations that follow the posi-
tion of the cursor as it moves around the screen.

What are Instances?
Once you create a symbol, or convert an object to a symbol, that symbol is stored
with the movie, but isn’t used directly on the Stage. Instead, you create instances
of that symbol. Instances are, in essence, copies of the original symbol, but they
differ in two major ways. First, an instance of a symbol doesn’t add significantly
to the file size of the movie, whereas a copy and an item would. Second,
instances are linked to their parent symbols, so if you change the symbol, the
instances of that symbol automatically change in the movie. But even though the
instances are linked to its symbol, you can change certain aspects of the instances
without breaking the link.

Let’s say that you want to have five buttons in your movie that look the same,
except you want them to be different colors. You could create five button sym-
bols, making each a different color. However, you could also create one button
symbol, and use five instances of that symbol, changing the color of each
instance. This would make the file size much smaller than if you created five
symbols.

movie clip symbol:
A symbol best used for
animations that are
independent of the main
movie Timeline.

button symbol:
A symbol that contains four
frames allowing you to create
buttons with visible changes
as the user interacts with
them.

instance:
A copy of a symbol, which
doesn’t add to file size and is
linked to its parent symbol.
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Topic 1B
Graphic Symbols
In order to apply motion-tweened animation to an object, it needs to be converted
to a symbol, since standard objects drawn within Flash can only use shape
tweens. Graphic symbols are best used for static images, or for animations that
you do not want to run independently of the main movie’s Timeline.

A graphic symbol’s Timeline looks identical to the main movie Timeline. You can
use multiple layers, masks, motion guides, and most other elements that you can
add to the Timeline of the main movie. However, you cannot add sounds or
movie clips within a graphic symbol’s Timeline.

You can create a graphic symbol using one of two methods. First, you can create
an object within Flash, and then use the Convert to Symbol command. This will
convert your shape to a symbol, and automatically turn your original shape into a
linked instance of that symbol.

Second, you can create a new symbol using the New Symbol command, and
work directly within the graphic symbol’s Timeline. When a graphic symbol only
includes a static image, either method works equally well. However, if you are
building animation within the symbol, it is easiest to work directly within the
symbol’s Timeline.

You will now create an object that will eventually form the basis for a button
using Flash’s drawing tools. You will then convert that object to a graphic
symbol.

TASK 1B-1:
Converting an Object to a Graphic Symbol

1. Launch the Flash MX application. The Flash application launches, and a
new, untitled movie appears.

2. You will use the Oval tool to draw a circle on the Stage. Using the Oval
tool, draw a circle on the Stage. With the circle selected, use the Prop-
erty Inspector to set the width and height of the circle to 150 pixels.

3. You will now remove the stroke from the circle. Remember that you can
simply click once on the circle’s edge to select the stroke. Click on the
edge of the circle to select its stroke, and press [Backspace].

4. You will now create a custom gradient for the circle’s fill. Click on the
circle to select it. Choose Linear from the Fill drop-down list in the
Color Mixer.

4 FlashMX - Level 2 (Windows)
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5. The gradient settings now appear in the Color Mixer. Click on the color
marker below the left edge of the gradient bar to select it.

6. Enter the following values in the Color Mixer: R-251, G-203, B-203. The
initial color of the gradient is set to a light pink.

7. You will define the ending color for the gradient. Click on the color
marker below the right edge of the gradient bar to select it.

8. Enter the following values in the Color Mixer: R-194, G-90, B-97. The
ending color of the gradient is set to a dark pink.

9. Now that you have created the gradient, you will save it to the Swatches
panel so that you can use it again. Choose Add Swatch from the Color
Mixer drop-down list. The gradient you defined is now saved in the Color
Swatches panel.

10. Next you will rotate the circle 90 degrees so the lighter color is at the top of
the circle. While you could use the Transform Fill tool, in this case, you do
not have to, since the shape is a circle. Instead, you can simply rotate the
entire circle. Making sure the circle is selected, type 90 in the Rotate field
in the Transform palette.

The gradient now moves in a vertical direction, with the lighter color on top.

11. Next you will copy the circle and then paste the duplicate to a new layer
that is above the original. Select the circle and choose Edit→Copy.

12. Click the Insert Layer button below the Timeline.

Lesson 1: Symbols and Instances 5
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13. Making sure the new layer is selected, choose Edit→Paste in Place. You
have pasted a duplicate of the circle directly on top of the original.

14. You will now choose a solid color fill for the duplicate circle. Choose Solid
from the Fill drop-down list in the Color Mixer. Enter the following val-
ues in the Color Mixer: R-255, G-152, B-159.

15. Next you will resize the duplicate circle using the Info palette so that the
duplicate is slightly smaller than the original. Click on the center dot in the
location proxy in the Info palette. This will keep the circle centered when
you resize it.

16. Using the Info palette, set the width and height of the circle to 140.

17. Once again, you will create a new layer and paste the duplicate in place on
the new layer. Create a new layer. There are now three layers in the
document. Making sure the top layer is selected, choose Edit→Paste in
Place. The duplicate is placed in the top layer.

18. Because you pasted the original gradient filled circle, the duplicate is still
filled with that gradient. You want the gradient of the duplicate circle to
have the darker color starting at the top of the circle and the lighter color at
the bottom. Once again, you can simply rotate the circle using the Transform
palette. With the new duplicate selected, type 270 in the Rotate field in
the Transform palette. The gradient is now rotated so it runs the opposite
direction of the original circle.

19. Using the Info palette, set the size of the new duplicate circle to 110.

20. Finally, you will create one more layer to place the final circle that will
comprise the basic bottle cap. Create a fourth layer, and paste the dupli-
cate circle in place once again.

21. You will use the same solid fill color as you used for the second circle. Set
the fill color to the following values in the Color Mixer: R-255, G-152,
B-159.

6 FlashMX - Level 2 (Windows)
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22. Using the Info palette, set the size of the circle to 85. The original bottle
cap is complete.

23. You will now select all of the elements that comprise the bottle cap. Choose
Edit→Select All.

24. You will now convert the selected bottle cap elements to a graphic symbol.
Choose Insert→Convert to Symbol. The Convert to Symbol dialog box
appears. Type Bottlecapin the Name field. Click the Graphic radio
button.

Click OK.

Lesson 1: Symbols and Instances 7
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25. You have created the symbol. Two things occur when you convert an object
or series of objects to a symbol. First, the symbol itself is added to the docu-
ment’s Library. Second, the original object is converted to an instance of that
symbol. which is located in the document’s Library. Choose Window→
Library.

You are now viewing the document’s Library. The Bottlecap symbol is
listed. In addition, the Property Inspector displays the information for the
selected bottle cap on the Stage, indicating that it is an instance of the
Bottlecap graphic symbol.

26. Choose File→Save. In the Save As dialog box, name the document
Bottlecap. Place the Bottlecap.fla document in the
Flash MX Level 2 Data folder. Close the Bottlecap document.

Topic 1C
Movie Clip Symbols
You have seen that graphic symbols can work well for static graphics. In addi-
tion, many Flash designers use graphic symbols for simple animations. However,
the animations in a graphic symbol have several limitations. First, a graphic sym-
bol cannot contain buttons or sounds. Second, a graphic symbol always plays in
conjunction with the main movie Timeline. If the main Timeline has fewer frames
than the graphic symbol’s animation, the animation won’t complete, and if the
main movie stops, so does the graphic symbol’s animation.

The animation in a movie clip symbol plays independently of the Timeline.
Therefore, movie clip symbols offer much more flexibility in creating animations.
You can use movie clip symbols to create animations that loop and repeat within
the main Timeline, even if the main Timeline stops. Movie clip animations can
contain sounds, and even buttons. You can combine movie clip symbols in the
main Timeline to create multiple animations. Further, you can use movie clip
symbols to add animation to a button state or to create dynamic rollovers. This is
just the beginning of what you can do with movie clip symbols.

You will now build a movie clip symbol that will contain a frame-by-frame
animation. You will then animate the symbol within the main movie Timeline,
and will combine that movie clip symbol with others to create a complex
animation.

8 FlashMX - Level 2 (Windows)
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TASK 1C-1:
Creating a Movie Clip Symbol

1. Create a new Flash document.

2. You will now create a movie clip symbol. In this case, instead of converting
existing content to a symbol, you will create the symbol first, and work with
the symbol’s Timeline directly. Choose Insert→New Symbol. The Create
New Symbol dialog box appears.

3. Type Paddling in the Name field. Click the Movie Clip radio button.

Click OK. Flash creates a new movie clip symbol. You are now viewing the
Paddling movie clip symbol’s Timeline. A movie clip symbol’s Timeline
looks identical to the main movie’s Timeline. However, you can tell that you
are viewing the symbol’s Timeline by viewing the selected item in the infor-
mation bar above the top left corner of the Stage. Currently, the Paddling
movie clip symbol appears there, so you know you are viewing its Timeline.

4. You will now import a series of images that was created in an external
image editing program. Because the files use a similar naming scheme and
are placed in the same location, Flash will recognize that they may be a
series. Choose File→Import. The Import dialog box appears. Navigate to
the Canoe Animation folder inside the Flash MX Level 2 Data folder.

5. Click on any one of the images in the folder, and click Open. An alert
box appears indicating that Flash recognizes the image as part of a sequence
of images.

Click Yes to import the images in the folder as a sequence. Flash imports
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the images, placing each image on a separate keyframe in the Timeline.

6. Next you will simply play the frame-by-frame animation within the movie
clip symbol’s Timeline. Press [Enter] to play the animation.

7. You will now return to the main movie Timeline. Click Scene 1 in the
information bar to view the main movie’s Timeline.

8. Because you began by creating a new symbol instead of converting existing
content to a symbol, there are no instances of the symbol on the Stage. You
will now add an instance of the Paddling movie clip symbol to the Stage.
Choose Window→Library to view the current document’s Library, if
necessary.

The Library contains the Paddling movie clip symbol, along with each of the
imported bitmaps that comprise the symbol. Any time you import a bitmap
image, it is automatically added to the Library.

9. Drag the Paddling movie clip symbol onto to the Stage, releasing the
mouse button when the instance of the symbol is approximately in the
center of the Stage.

10 FlashMX - Level 2 (Windows)
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10. When you want to view a movie clip symbol in the main movie Timeline,
you cannot simply play the movie, because the movie clip symbol’s anima-
tion runs independently of the main movie Timeline. Instead, you need to
preview the movie. Choose Control→Test Movie. Flash creates a SWF file
from the Flash file, and displays it in a Preview window. You can now see
the movie clip symbol’s animation looping repeatedly.

11. You will save the file. Close the Preview window. You return to the Flash
movie. Choose File→Save. In the Save As dialog box, name the file
Paddling Animation, and save it inside the Flash MX Level 2 Data
folder.

Combining Movie Clip Symbols
As mentioned before, one advantage of using movie clip symbols for animations
is that you can combine them in the main movie Timeline to create more com-
plex animation sequences.

You will combine the Paddling movie clip symbol’s animation with an additional
animation to create a complex scene.

TASK 1C-2:
Combining Multiple Movie Clip Symbols

1. You will now open an existing Flash document that contains some objects
you will use to build a more complex animation. Open the Water Scene.fla
document located inside the Flash MX Level 2 Data folder. The
Water Scene document contains two waves objects that have already been
converted to graphic symbols. In addition, each of the symbol instances have
been placed on their own layer in the document.

2. You will now create an animation sequence that consists of the wave objects
and the Paddling movie clip symbol from the Paddling Animation movie.
You will begin by importing the Paddling movie clip symbol by simply
dragging and dropping between the libraries of the Paddling Animation and
Water Scene documents. Choose Window→Paddling Animation to view
the Paddling Animation document. Choose Window→Library, if the
Paddling Animation Library is not showing.

3. Choose Window→Water Scene to view the Water Scene document.
Choose Window→Library, if the Water Scene Library is not showing.

4. Drag the Paddling movie clip symbol from the Paddling Animation
Library into the Water Scene Library. The Paddling movie clip symbol
and the associated image files are all copied to the Water Scene Library.
Now that the symbol is in the Water Scene document, you can use it.
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5. Close the Paddling Animation document and Choose Window→Water
Scene to view the Water Scene document, if necessary.You will add an
instance of the Paddling movie clip symbol to the Stage, and will then ani-
mate it. You will begin by creating a new layer, placing it below the Front
Waves and Back Waves layers. Click the Insert Layer button. Name the
new layer Canoe. Move the Canoe layer below the Front Waves and
Back Waves layers.

6. You will now place an instance of the Paddling movie clip symbol on the
Stage. Making sure that the Canoe layer is active, drag an instance of
the Paddling movie clip symbol to the Stage. Place the instance so it
appears that the canoe is partially in the water. You have added an
instance of the symbol.

7. Once again, you will preview the movie. Press [Ctrl][Enter]. A Preview
window appears displaying the movie. The Paddling movie clip symbol’s
animation looping continuously. While the main Timeline only contains one
frame, the entire movie clip animation is able to play, because its animation
is independent of the Timeline. If the Paddling animation were placed inside
a graphic symbol, only the first frame of the animation would show.Close
the Preview window.

8. While you can obviously have animation within a movie clip symbol, you
can additionally animate the symbol itself within the context of the main
movie Timeline. You will have the canoe rotate slightly to appear as if it is
being carried by the waves, as the looping animation plays. To do this, you
create a simple motion tween with several keyframes.

You will first extend the Timeline for all of the layers so they will be visible
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for the duration of the motion tween. Drag in frame 60 from the Front
Waves layer down to the Canoe layer. Choose Insert→Frame. You have
extended the Timeline for all of the layers to frame 60.

9. Next you will create keyframes for motion tween. Click on frame 20 of the
Canoe layer, and choose Insert→Keyframe.

10. Create keyframes at frame 40 and frame 60 in the Canoe layer.

11. You are now ready to create the motion tween. Click on the keyframe in
frame 20 in the Canoe layer. You will rotate the Paddling instance. How-
ever, its transform point is currently set to its top left corner. You will reset
the transform point so it is at the center of the movie clip symbol. Choose
Modify→Transform→Free Transform. Drag the transform point from
the top left corner of the Paddling instance to its center.

12. You can now enter a value in the Rotate field in the Transform palette. Type
10 in the Rotate field in the Transform palette. You have set the rotation
value for the keyframe at frame 20.

13. Click on frame 40 in the Canoe layer. Set the transform point to the
center of the Paddling instance, and type –10 in the Rotate field in the
Transform palette. You have set the rotation value for frame 40.

14. The keyframes at frames 1 and 60 already have the rotation value set to 0,
which is what you want. However, you need to set the transform point for
the those keyframes so it is in the center of the Paddling instance. Click on
frame 1 in the canoe layer. Set the transform point to the center of the
Paddling instance. Set the transform point to the center of the Paddling
instance in frame 60.
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15. At this point, you are ready to establish the motion tweens. Click on any
frame in the Canoe layer between frame 1 and 20, and choose Insert→
Create Motion Tween. You have created the first motion tween. Add a
motion tween between frames 20 and 40. Add a third motion tween
between frames 40 and 60.

16. You are ready to view the animation. Press [Enter] to view the animation.
The movie clip symbol moves. However, only the first frame of the Paddling
animation is visible. In order to see the independent Paddling animation
within the movie clip, you need to preview the movie.

17. Press [Ctrl][Enter]. The movie plays in a Preview window. The Paddling
animation continuously loops, while the instance of the movie clip is ani-
mated by the motion tween.

18. Close the Preview window, and save the Water Scene document.

Multiple Movie Clip Symbols
Within the same main movie Timeline, or even within movie clip Timelines, you
can embed multiple movie clip symbol instances. This allows you to create com-
pletely independent animations that use different durations, and that can be
altered as necessary.

You will now animate the waves objects as a movie clip, and add it to the main
movie Timeline so that you can have multiple independent animations running.

TASK 1C-3:
Combining Multiple Movie Clip Symbols

1. Each of the waves objects has already been converted to a graphic symbol.
You will now create a movie clip symbol that will contain the animation of
the waves.Choose Insert→New Symbol. The Create New Symbol dialog
box appears. Type Waves Animationin the Name field, click the Movie
Clip radio button, and click OK. You are now viewing the movie clip
symbol’s Timeline.

2. You will now prepare the layers in the Timeline for the two waves objects.
Rename Layer 1 to Back Waves.

3. Create a new layer and name it Front Waves. Make sure the Front
Waves layer is above the Back Waves layer.
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4. You are ready to place an instance of the Back Waves graphic symbol into
the first frame of the Back Waves layer. Click on the first frame of the
Back Waves layer. Drag an instance of the Back Waves graphic symbol
from the Library window to the Stage.

5. You will resize the instance of the Back Waves symbol so it extends 50 pix-
els beyond the left and right edges of the Stage. Making sure the Back
Waves instance is selected, enter the following values in the Info palette:
Width: 650, X: 0, Y: 0. When you set the center point of the object so that
its X and Y values are 0, the center point of the object line’s up with the
registration point of the symbol. This becomes important as you place sym-
bol instances on the Stage within other symbol Timelines, or within the main
movie Timeline.

6. Click on the first frame of the Front Waves layer. Drag an instance of
the Front Waves graphic symbol from the Library window to the Stage.

7. You will also resize and position the Front Waves instance using the Info
palette. Click on the Front Waves instance to select it, and type 650 in
the Width field in the Info palette. Line up the bottom, left, and right
edges of the Front Waves instance with the bottom, left, and right edges
of the Back Waves instance. (Hint: You can use the arrow keys to nudge
the selected instance on pixel at a time.)

8. You will now create several motion tweens for each of the waves objects.
You will begin by creating the keyframes. Drag from frame 12 in the
Front Waves layer down to frame 12 in the Back Waves layer. You have
selected frame 12 in both layers. Choose Insert→Keyframe. Keyframes are
added to frame 12 for both layers.

9. You will add keyframes to both layers at frames 24, 36, and 48. Drag from
frame 24 in the Front Waves layer down to frame 24 in the Back Waves
layer. Choose Insert→Keyframe.

10. Insert keyframes in both layers at frames 36 and 48.

11. You will now set the position of each waves object in each keyframe. Click
on the keyframe at frame 12 in the Front Waves layer. Type 50 in the X
field in the Info palette.

12. Click on the keyframe at frame 24 in the Front Waves layer. Make sure
that the value in the X field in the Info palette is 0.

13. Click on the keyframe at frame 36 in the Front Waves layer. Type –50
in the X field in the Info palette.
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14. Click on the keyframe at frame 48 in the Front Waves layer. Make sure
that the value in the X field in the Info palette is 0.

15. You are ready to build the motion tweens for the Front Waves layer. Right-
click in the Front Waves layer between the first two keyframes, and
choose Create Motion Tween from the shortcut menu. You have created
the motion tween.

16. Create motion tweens for the remaining keyframes in the Front Waves
layer.

17. Next you will specify the object positions at each keyframe for the Back
Waves object.Click on the keyframe at frame 12 in the Back Waves
layer. Type –50 in the X field in the Info palette.

18. Click on the keyframe at frame 36 in the Back Waves layer. Set the X
value in the Info palette to 50. Make sure the X value is set to 0 in the
Info palette in the keyframes at frames 24 and 48 in the Back Waves
layer.

19. Create motion tweens between each of the keyframes in the Back Waves
layer.

20. You have finished creating the animation within the Waves Animation movie
clip symbol. You will now view the main movie Timeline once again. Click
Scene 1 in the information bar to view the main movie Timeline.

21. You will now alter the main movie Timeline for the Water Scene document.
You will begin by deleting both the Front Waves and Back Waves layers
from the Timeline. This will also remove the original instances of the Front
Waves and Back Waves graphic symbols. You will then create a new layer
that will contain an instance of the Waves Animation movie clip symbol.
Click on the Front Waves layer in the Timeline. Click the Delete Layer
button . Delete the Back Waves layer.

22. Next you will create a new layer to contain an instance of the Waves Anima-
tion movie clip symbol. Create a new layer called Waves. Make sure the
Waves layer is above the Canoe layer in the Timeline.

16 FlashMX - Level 2 (Windows)
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23. Click on frame 1 in the Waves layer to select it. Drag an instance of the
Waves Animation movie clip symbol to the Stage. Set the X value in the
Info palette to 275, and line up the bottom edge of the movie clip sym-
bol instance with the bottom edge of the Stage.

24. You will now preview the movie. Press [Ctrl][Enter]. Flash displays the
animation in a Preview window. Close the Preview window, and save the
file.

Nested Movie Clip Symbols
When you viewed the movie, you could see both the Waves Animation and Pad-
dling animation sequences continuously looping. However, each animation looped
for a different reason. The Waves Animation sequence looped because it is an
instance a movie clip symbol. The motion-tweened Paddling animation sequence
looped because the entire movie loops by default.

You can vastly simply the main movie Timeline for the Water Scene movie. To
accomplish this, you can simply convert the motion tween of the Paddling movie
clip symbol instance into a new movie clip symbol. What you are essentially
doing is nesting an instance of the Paddling movie clip symbol along with its
motion tween into a new movie clip symbol. Once you do this, the main movie
will simply consist of two movie clips; one for the motion-tweened Paddling
symbol instance, and one of the Waves Animation. Because the only animation in
the movie is occurring within movie clip symbols, you can reduce the movie
Timeline to a single frame.
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TASK 1C-4:
Nesting Movie Clip Symbols

1. To convert an existing animation to a movie clip symbol, you simply need to
copy the frames that comprise the animation, and paste them into the movie
clip symbol’s Timeline. Click on the Canoe layer name in the Timeline.
All of the frames in the Canoe layer are selected, along with the objects and
defined tweens in those frames.

2. Choose Edit→Copy Frames.

3. Create a new movie clip symbol called Paddling Animation.

4. In the Paddling Animation movie clip Timeline, click on the first frame.
Choose Edit→Paste Frames. The single layer is renamed Canoe and the
animation is pasted into the Timeline. The movie clip symbol is complete.

5. View the main movie Timeline.

6. You will now alter the main movie Timeline so you can place an instance of
the Paddling Animation movie clip. Drag in the Timeline from frame 2 in
the Waves layer to frame 60 in the Canoe layer. All of the frames except
the first are selected. Choose Insert→Remove Frames. The Timeline is
now one frame in duration.

7. Next you will swap the instance of the Paddling movie clip symbol, so you
can replace it with an instance of the Paddling Animation movie clip sym-
bol, which contains the motion tween. Click on frame 1 in the Canoe
layer, and click on the instance of the Paddling symbol to select it. Press
[Backspace].

8. Drag an instance of the Paddling Animation movie clip symbol from the
Library palette to the Stage.
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9. The Timeline is complete. Press [Ctrl][Enter] to preview the movie. The
animation looks the same as before, but the Timeline is much simpler.

10. Close the Preview window. Save and close the Water Scene document.

Topic 1D
Button Symbols
A button symbol’s Timeline differs from the Timelines of a graphic or movie clip
symbol. A button symbol’s Timeline consists of only four frames; one for each
button state. The four button states are Up, Over, Down, and Hit. The Up state
appears when the button is in its normal, default state. The Over state appears
when the viewer moves their cursor over the button. The Down state appears
when the viewer clicks on the button. Finally, the Hit state doesn’t actually create
a visual change. Instead, it defines the hot area of a button, if you want to desig-
nate one that is a different shape or area than the contents of the other button
frames.

By placing keyframes in each of the four frames, you can control the effect of the
cursor interacting with the button symbol. Just as with a Timeline in a graphic or
movie clip symbol, you create keyframes when you want the content to change in
a particular frame, so you do not necessarily need to define a keyframe for each
frame. For example, if you are building a button that changes only when the
viewer clicks on it, you only will have keyframes in the Up and Down frames,
but not the Over and Hit frames.

You will begin by creating a simple button that consists of static image states. In
this case, the button will change appearance when the viewer moves the cursor
over the button, and will change to a different appearance when the viewer clicks
on the button.

TASK 1D-1:
Creating a Button Symbol with Static Image States

1. Open the Bottlecap document located inside the Flash MX Level 2 Data
folder. The Bottlecap file, which you created earlier, contains a single
graphic symbol called Bottlecap.

2. You will now create a new button symbol using the Bottlecap graphic sym-
bol as its basis.Choose Insert→New Symbol. The Create New Symbol
dialog box appears. Type Bottlecap Buttonin the Name field. Click the
Button radio button, and click OK. You are now viewing the button sym-
bol’s Timeline, which consists of four frames.
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3. You will now build the button using static image states, beginning with the
Up state. Choose Window→Library to view the document’s Library
palette. Drag an instance of the Bottlecap graphic symbol to the Stage.
You will now align the center of the graphic symbol to the center of the
Stage. It’s often important to align elements to the registration point on the
state so that you can create subtle and precise variations within an animation
or a change in an image state. The easiest way to do this is to use the Info
palette.

4. Click on the center dot in the location proxy in the Info palette, and
type 0 in both the X and Y fields. The Bottlecap graphic symbol now lines
up with the registration point.

You want a spiral shape to appear in the center of the button when the
viewer moves the cursor over the button. To do this, you will add a
keyframe to the Over frame. Just as you do with a regular Timeline, in order
for there to be change to the content, you need to add a keyframe. By
default, the new keyframe will inherit the content from the previous one, so
you generally build your Timelines from left to right.

5. You will now begin by creating a new layer in the button symbol’s Timeline
to place the spiral shape. Create a new layer. Name the layer Spiral, and
make sure that the Spiral layer is above the original layer. Change the
name of the original layer to Button.

6. Next you will create a keyframe in the Over frame of the Spiral layer.Click
on the Over frame in the Spiral layer and choose Insert→Keyframe.

7. You will also add a frame to the Button layer, so that the button shape still
appears in the Over frame. Click on the Over frame in the Button layer,
and choose Insert→Frame. You do not want to insert a keyframe here,
because you are simply extending the content from the previous frame.

8. Now you will open an existing Flash file that contains the spiral shape.
However, since the shape is in the other file’s Library, you can simply open
the Library without opening the document. Choose File→Open as Library.
The Open as Library dialog box appears. Select the Spiral.fla document
inside the Flash MX Level 2 Data folder, and click Open. The Spiral
file’s Library appears in a separate Library palette.
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9. Click on the Over keyframe in the Spiral layer. Drag the Spiral graphic
symbol from the Spiral Library palette to the Stage. The Spiral graphic
symbol is added to the current document’s Library, and the instance of the
symbol is now on the Stage. With the Spiral instance selected, type 0 in
the X and Y fields in the Info palette to line up the Spiral instance with
the registration point.

10. Finally, you will create another visual change for the Down frame, which
will appear while the user holds the mouse button down on the button. You
will create a soft glow that will appear around the button. Create a new
layer called Glow, and move the layer to the bottom of the stacking
order in the Timeline. Click on the Down frame in the Glow layer, and
choose Insert→Keyframe.

11. Make sure the keyframe in the Down frame in the Glow layer is
selected. Using the Oval tool, draw a circle. Set its width and height to
150 using the Info palette. Use the Info palette to set its center point to 0
for both the X and Y values.

12. Fill the circle with pale yellow, and remove the stroke from the circle.

13. You will now create a fuzzy edge around the circle to create the glow effect.
Choose Modify→Shape→Soften Fill Edges. The Soften Fill Edges dialog
box appears. Type 8 in the Distance field. Leave the value in the Number
of Steps field at 4.

Click OK.
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14. You will now extend the Spiral and Button layers to the Down frame so that
the both the button shape and the spiral shape continue to appear when the
button is pressed. Select the Down frame in both the Spiral and Button
layers, and choose Insert→Frame. The button shape now appears in all
three frames. The spiral shape appears in the Over and Down frames, and
the glow only appears in the Down frame.

15. You have completed the button. You will now view the main movie
Timeline, where you can drag an instance of the button you created to the
Stage. Click Scene 1 in the information bar.

16. Delete the instance of the Bottlecap graphic symbol from the Stage.
Drag an instance of the Bottlecap Button button symbol from the
Library to the Stage.

17. You will now test the button. In order to see buttons operate, you need to
test the movie. Press [Ctrl][Enter]. Flash displays the movie a preview
window. Move the cursor over the button. The content in the Over frame
now appears. Click on the button. While the mouse button is actually
pressed down, the content of the Down frame appears. Close the Preview
window, and save the file.

Working with Animated Button States
While buttons with static image states are certainly impressive, you can add even
more dramatic impact to your buttons by using animated image states. By adding
a movie clip symbol to one of the button’s frames, the movie clip symbol’s ani-
mation will play continuously while the mouse is interacting with the button in a
way that triggers that particular frame. For example, you can place a movie clip
symbol in the Over frame of a button, and while the cursor is over the button in
the movie, the movie clip’s animation will play.

Remember that because a movie clip symbol plays independently of the main
movie Timeline, a movie clip’s animation can play within a single frame. For this
reason, if you want to add animation to a button state, you must use a movie clip
symbol. Animation within a graphic symbol will not work, because a graphic
symbol’s animation will only play when there are enough frames in the Timeline.

You will alter the Over frame of the button so that the spiral rotates while the
cursor is over the button. To do this, you will create a new movie clip symbol
with the Spiral shape rotating.
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TASK 1D-2:
Creating a Button with Animated Image States

1. Create a new movie clip symbol called Spiral Animation. You are view-
ing the Spiral Animation movie clip’s Timeline.

2. Drag an instance of the Spiral graphic symbol to the center of the Stage,
and line up the center of the spiral shape with the registration point.

3. Next you will create a motion tween. Remember that this animation will
loop because it is part of a movie clip symbol. You have will have the spiral
shape rotate. Click on frame 12 in the Timeline. Choose Insert→
Keyframe.

4. You will now add a motion tween between the keyframes in frames 1 and
12. Right-click in the Timeline between the two keyframes, and choose
Create Motion Tween from the shortcut menu.

5. You will now use the Property Inspector to set up the motion tween. Choose
CW from the Rotate drop-down list in the Property Inspector. Type 1 in
the Times field in the Property Inspector, if necessary. You have set the
motion tween to have the shape rotate one time clockwise.

6. You have completed the Spiral Animation movie clip symbol. Next you will
return to the Bottlecap Button Timeline, so that you can replace the static
Spiral graphic symbol in the button’s Over frame with the Spiral Animation
movie clip symbol. Double-click on the Bottlecap Button symbol in the
Library. The Bottlecap Button symbol’s Timeline appears.

7. Click in the Over frame in the Spiral layer, and delete the instance of
the Spiral graphic symbol.

8. Drag an instance of the Spiral Animation movie clip symbol from the
Library to the Stage, and use the Info palette to set the instance’s
centerpoint so it lines up with the registration point on the Stage.

9. You will now create a keyframe in the Down frame of the Spiral layer, and
you will place an instance of the Spiral graphic symbol. This will cause the
static spiral shape to appear along with the glow around the button when the
button is pressed. Click on the Down frame of the Spiral layer, and
choose Insert→Blank Keyframe. By inserting a blank keyframe, the con-
tents of the Over frame of the Spiral layer do not carry over to the Down
frame. With the keyframe in the Down frame of the Spiral layer
selected, drag an instance of the Spiral graphic symbol to the Stage, and
use the Info palette to set the instance’s centerpoint so it lines up with
the registration point on the Stage.

10. You are ready to test the button. Click on Scene 1 in the information bar
to view the main movie. Press [Ctrl][Enter] to preview the movie.
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11. Move the cursor over the button. The animation plays.

12. Click on the button. The spiral shape stops spinning, and the glow appears
around the button.

13. Close the Preview window and save the file.

Topic 1E
Managing Symbols and Instances
You have seen a little bit about symbols as you have created each symbol type.
However, using Flash’s symbol management tools, and clearly understanding the
relationship between symbols and instances can make it much quicker and easier
to build your projects, and can help you keep your file size (and download time)
down.

As you have seen, there are two ways to create symbols. You can either convert
content that already exists on the Stage to a symbol, or you can create a new
symbol and create content directly in the symbol’s Timeline. However, while
symbols are the building blocks of your Flash projects, it’s the instances of the
symbols that actually provide content that the viewer accesses.

You will now work with the Bottlecap movie, creating several instances of the
animated button symbol. This will help you to see how creating a button symbol
and working with instances saves you time when you use that symbol multiple
times in your project.

TASK 1E-1:
Creating Instances

1. Make sure you are viewing the Bottlecap movie’s main Timeline. You
will now remove all of the layers except one, since you only needed the
various layers to build the original button symbol. Click on Layer 4. While
holding down the [Shift] key, click on Layer 2. Click the Delete Layer
button. The Timeline now has a single layer and a single frame.

2. Next you will add instances of the Bottlecap Button symbol. Drag an
instance of the Bottlecap Button symbol to the Stage.

3. You can resize an instance without breaking the link to the original symbol.
With the instance selected, type 50 in the Width field in the Transform
palette, and press [Enter]. The instance of the button is resized to 50
percent.

4. You can also duplicate an instance without needing to drag a symbol from
the Library. With the button instance selected, choose Edit→Duplicate. A
duplicate instance appears. Drag the duplicate button instance below the
original.
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5. You will now test the button instances. Press [Ctrl][Enter] to test the
movie. The Preview window appears. Move the cursor over the button
instances, and click on them to see the buttons operate. Close the Pre-
view window.

6. When you use instances, you maintain a link to the original symbol, so if
you change the symbol, the instances will change. Remember that the
Bottlecap button symbol uses the Spiral Animation movie clip symbol,
which in turn uses the Spiral graphic symbol. You will now alter the Spiral
graphic symbol to see how it affects the symbols based on it, and the
instances of those symbols. Double-click on the Spiral graphic symbol in
the Library. You are viewing the Spiral graphic symbol’s Timeline.

7. Click on the spiral shape on the Stage, and choose Modify→Ungroup.
The spiral shape is ungrouped, so you can alter the various objects that com-
prise the shape.

8. You will change the white portions of the spiral shape to pale yellow. Click
on one of the white portions of the spiral shape and select a pale yellow
fill color.

9. Fill the remaining white portions of the spiral with the same pale yellow
fill color.

10. Click on Scene 1 in the information bar to view the main movie
Timeline.

11. You will once again test the buttons. Press [Ctrl][Enter] to test the movie.
Once again, the Preview window appears. Move the cursor over the
buttons. The buttons now use the new spiral color for both the spiral anima-
tion in the Over frame, and the static spiral shape in the Down frame,
because the Spiral Animation movie clip symbol uses the Spiral graphic
symbol as its basis.

12. Close the Preview window. Save the Bottlecap file and close it.

The Document Library
Each Flash document has its own Library. This is separate from the Flash com-
mon libraries that contain pre-formatted buttons, sounds, and other elements. As
you have already seen, the Library belonging to each Flash document is where
symbols that you create in Flash and imported graphics (which are automatically
converted to symbols when you import them) reside.

Once symbols are in the Library, you can access them, organize them, examine
them, and otherwise manage these many building blocks that make up your
projects.
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As you have seen, using symbols can make content creation quicker. For
example, you used the Spiral graphic symbol as the basis for the Spiral Anima-
tion movie clip symbol, instead of building the animation completely from
scratch. Additionally, if you make a change to the Spiral graphic symbol (chang-
ing its color, for example), the Spiral Animation movie clip symbol will
automatically update to reflect that change.

When you do use symbols as the building blocks for your projects, as you
should, you wind up with a lot of symbols. This is where the ability to organize
them can really come in handy. In a Flash Library, you can create a hierarchy of
folders and subfolders to store groups of symbols.

TASK 1E-2:
Using the Symbol Library

1. You will open another file that contains a Library with a relatively large
number of symbols. Open the Preloader Flash file located in the
Flash MX Level 2 Data folder. Choose Window→Library.

The file contains a large number of symbols. The text was broken apart, and
each individual character was saved as a graphic symbol. In addition,
another graphic symbol—Animated L—contains animation that was created
from the first letter in the text Loading.

2. You will now organize the symbols using the tools in the Library palette.
First, you can change the way you are viewing the symbols in the Library.
You can choose to view the Library palette in narrow or wide view. Click
the Wide Library View button in the top right corner of the
Library palette. You now see more information about each symbol, which
will be useful as you add instances of the symbols to your project, and link
symbols to a shared Library.

3. Additionally, you can change the order that you are viewing symbols. Click-
ing on a column heading in Library palette sorts the symbols by that
column’s information, and clicking the Sorting Order button toggles the sort-
ing order within the column. Currently you are viewing the symbols in
alphabetical order using the symbol’s name. Click the Sorting Order but-
ton . The symbols reverse order. Click the Sorting Order button again.
The symbols return to their original order.
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4. You will now organize the symbols into folders. By creating folders, you can
make it easier to locate symbols you need more quickly. You will begin by
creating a folder to contain the graphic symbols that will make up the ani-
mated preloader. Click the New Folder button in the Library
palette. Flash creates a new folder in the Library palette.

5. Type Static Textand press [Enter].

6. You will now move the text graphic symbols into the folder to make the
Library window’s items more manageable. Click on the“a” graphic symbol
in the Library window. While holding down the [Shift] key, click on the
“o” graphic symbol. All of the symbols within the range are selected. You
now need to deselect the symbols you do not want to place in the folder.
You can select or deselect individual items by clicking on them while hold-
ing down the [Ctrl] key.

7. While holding down the [Ctrl] key, click on the Circle graphic symbol,
and the Animated L symbol, if necessary. Drag any of the selected sym-
bols to the Static Text folder. The selected symbols are placed inside the
folder.

8. To view the contents of a folder, you simply double-click on its icon.
Double-click on the Static Text folder icon. The folder expands to display
its contents. You can collapse the folder by double-clicking on it a second
time.

9. Save and close the Preloader Flash document.

Duplicating Symbols
You will now build content quickly by duplicating symbols and altering them.
Remember that when you base one symbol on another, if you change the parent
symbol, the child symbol will also change. This lets you create multiple objects
much faster, and lets you update the child objects automatically if the parent
objects change.

You will build a new Flash document that will contain a series of buttons you
will use for navigation. The buttons will be based on the animated Bottlecap But-
ton button symbol you created in the Bottlecap Flash document.
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TASK 1E-3:
Duplicating and Altering Symbols

1. You will begin by creating a new Flash document, and then opening the
Bottlecap Flash file as a Library. Create a new Flash document. Choose
File→Open as Library. In the Open as Library dialog box, select the
Bottlecap.fla document inside the Flash MX Level 2 Data folder. Choose
Window→Library to view the document’s Library palette.

2. Drag the Bottlecap Button button symbol from the Bottlecap Library
palette to the new document’s Library palette. All four symbols move to
the new document’s Library palette because the Bottlecap Button symbol
uses the Bottlecap, Spiral, and Spiral Animation symbols. Collapse the
Bottlecap Library palette.

3. You want the Up state of each button in the navigation bar to display a label
for the button. You want that label to disappear when the viewer moves the
cursor to the button. The easiest way to do this is to create additional button
symbols based on the original that contain the text label in the Up frame.
Click on the Bottlecap Button symbol in the Library palette, and choose
Duplicate from the Library drop-down list. The Duplicate Symbol dialog
box appears. Name the duplicate symbol History Button. Double-click on
the History Button symbol in the Library palette to view its Timeline.

4. You will now add a text label to the button in the Up frame. Create a new
layer above the others called Text. Click on the Up frame in the Text
layer. Using the Text tool, create a History label. Format the label using
Arial, bold, 18 point, black text. Use the Info palette to line up the His-
tory label with the center of the button.

5. Because you want the text to disappear when the cursor is moved over the
button, you need to create a blank keyframe in the Text layer in the Over
frame. Otherwise, the text will stay visible within the other button states.
Click on the Over frame in the Text layer, and choose Insert→Blank
Keyframe.

6. Now that you have created the History Button symbol, you will create a Fla-
vors Button symbol using the History Button as its basis. Click on the
History Button symbol in the Library palette, and choose Duplicate
from the Library drop-down list. In the Duplicate Symbol dialog box,
name the symbol Flavors Button.

7. Double-click on the Flavors Button symbol in the Library palette to
view its Timeline.
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8. To complete the Flavors button, you simply need to edit the History label in
the Up frame of the Text layer. Click on the Up frame in the Text Layer.
Select the History label, and change the text to Flavors. Make sure the
center point of the text label lines up with the registration point. You
have completed the Flavors Button.

9. You will now create one more button symbol based on the History Button
symbol. Duplicate the History button symbol once again. Name the sym-
bol Merchandise Button. View the Merchandise Button symbol’s
Timeline. Change the label for the Merchandise Button in the Up frame
of the Text layer to Merch. Make sure the center point of the text label
lines up with the registration point. You have completed the Merchandise
Button symbol.

10. You will now place an instance of each of the button symbols you built on
the Stage.View the main movie Timeline. Drag an instance of the History
button to the Stage. Drag an instance of the Flavors and Merchandise
buttons to the Stage.

11. Select the three button instances on the Stage, and use the Transform
palette to scale them to 50%.
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12. Arrange the button instances as shown below. (Hint: Use the Align pal-
ette to align and distribute the buttons on the Stage.)

13. Press [Ctrl][Enter] to test the movie. Each button shows the its label in its
Up state, the animated spiral shape in its Over state, and the static spiral and
glow in its Down state. Close the Preview window.

14. Save the document, naming it Navigation, and placing it inside the
Flash MX Level 2 Data folder.

Swapping Symbols
In the Preloader Flash file, one animation has already been created. It is the
graphic symbol Animated L that animates the letter L in Loading, using the L
graphic symbol as its basis. As you learned before, graphic symbols may contain
animation. The main difference between a graphic symbol’s animation and a
movie clip symbols’ animation is that the movie clip’s animation is independent
of the main Timeline, while the graphic symbol’s animation is subject to the main
Timeline. If you do not want the animation to loop independently, a graphic sym-
bol is often preferable.
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You will now create additional movie clip symbols to animate the other charac-
ters in the preloader animation. To do this, you do not have to create everything
from scratch. Flash gives you the ability to quickly change the symbol or sym-
bols that are used within another symbol. Because of this, you can simply
duplicate and rename the Animated L graphic symbol, and then change the
graphic symbol it uses as the basis of its animation.

TASK 1E-4:
Using Symbol Swapping

1. Open the Preloader Flash file inside the Flash MX Level 2 Data folder.
View the document’s Library.

2. You will begin by examining the Animated L graphic symbol. Double-click
on the Animated L graphic symbol in the document’s Library palette to
view its Timeline.

3. The Animated L is in the center of the Stage. Click on the registration
mark to select the L graphic symbol. By examining the Property Inspector,
you can see that the Animated L graphic symbol uses the L graphic symbol
as its basis. You will now duplicate the Animated L graphic symbol, and
then in the duplicate, you will change the graphic symbol used as its basis.

4. Making sure the Animated L graphic symbol is selected in the Library
palette, choose Duplicate from the Library drop-down list. The Duplicate
Symbol dialog box appears. Type Animated oin the Name field, make
sure that the Graphic radio button is selected, and click OK.

5. You now simply need to open the Animated o graphic symbol you just cre-
ated, and swap the L graphic symbol used within with the o graphic symbol.
Double-click the Animated o graphic symbol in the Library palette to
view its Timeline. Click on the keyframe in frame 1 of the Text layer.
Click on the selected text object on the Stage, and click Swap in the
Property Inspector. The Swap Symbol dialog box appears. Click o in the
symbol list, and click OK. The Animated o graphic symbol now uses the o
graphic symbol as its basis. You can preview the animation by clicking the
Preview button in the Library window. Click the Preview button in the
Library window. The animation plays. It now uses the o symbol.

6. Using the above steps, create animated graphic symbols to animate each
of the remaining characters in the word Loading.

7. Create a new folder in the Library palette called Animated Text and
place all the animated graphic symbols you created into the folder.
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8. You want each of the animated graphic symbols to begin playing at a
slightly different time to create a rippling effect. In general, you do not want
to place multiple animated objects on the same layer in a Timeline, as this
can severely slow down performance. Additionally, it is often easier to alter
animations if each object is on a separate layer. You will now create a layer
for each graphic symbol instance. View the main movie Timeline. Create a
new layer, naming it L. Create additional layers, naming them o, a, d, i,
n, and g.

9. You will extend the Timeline for all of the layers so that it spans 25 frames.
Drag in frame 25, from the top layer to the bottom, and choose Insert→
Frame. You have extended the Timeline for each layer to frame 25.

10. You will now create keyframes for each of the layers, so that the movie clips
containing the animated text can be staggered on the main Timeline. You
already have a keyframe in frame 1 of the L layer by default, so you will
begin with the o layer. Create a keyframe in frame 3 of the o layer. Cre-
ate a keyframe in frame 5 of the a layer. Continue creating keyframes in
each layer two frames after the previous layer’s keyframe.

11. Next you will copy and paste each of the letters in the word Loading cur-
rently in Layer 1 into its correct layer, in the correct keyframe. Later, you
will swap those letters with instances of the animated text. Click on the
keyframe in frame 1 in the Layer 1 layer. Click on the L to select it.
Choose Edit→Cut. Click on the keyframe in frame 1 of the L layer.
Choose Edit→Paste in Place.

12. Click on the o on the Stage to select it. Choose Edit→Cut. Click on the
keyframe in frame 3 of the o layer. Choose Edit→Paste in Place.
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13. Continue cutting and pasting in place to place all of the letters in the
appropriate keyframe on the appropriate layers. Delete the Layer 1
layer.

14. Now to complete the preloader, you are going to build, you will simply
swap each of the static text symbols with the animated graphic symbols in
each keyframe. This will allow you to have the animated symbols positioned
exactly. Click on the keyframe in frame 1 of the L layer. Click on the
letter L on the Stage to select it. Click Swap in the Property Inspector.
The Swap Symbol dialog box appears. Choose Animated L in the Ani-
mated Text folder in the symbol list and click OK. You have swapped the
static text instance with the animated instance.

15. Swap each of the static graphic symbols for their animated counterparts.
You have completed the initial preloader animation.

16. Press [Ctrl][Enter] to test the movie and preview the animation.

17. Close the Preview window.

18. Finally, you will copy the entire preloader animation you just created to a
movie clip symbol, so that you can easily use it in another Flash file.
Choose Edit→Select All Frames. Choose Edit→Copy Frames. Create a
new movie clip symbol called Loading Animation. Click on the first
frame in the movie clip symbol’s Timeline, and choose Edit→Paste
Frames. All of the layers and objects are pasted into the movie clip sym-
bol’s Timeline.

19. Save and close the Preloader file.

Summary
In this lesson, you learned about the three symbol types and the best use of
each one. You created graphic symbols for text and animation, movie clip
symbols for independent animations, and button symbols to create naviga-
tion controls. You learned how to use symbols within other symbols, and
how to combine symbols and instances to create content, as well as to use
the Library to organize symbols.
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Lesson Review
1A What are the three types of symbols available in Flash?

Graphic, movie clip, and button symbols.

1B How do you convert an object to a symbol in Flash?

Select the object, and choose Insert→Convert to Symbol.

1C How does animation in a movie clip symbol differ from animation in a
graphic symbol when viewed in the main movie Timeline?

Animation in a movie clip symbol plays independently of the main Timeline,
so the entire animation only uses one frame in the main Timeline. Animation
in a graphic symbol is dependent on the main Timeline, so if the main
Timeline stops, or if there are not enough frames in the main Timeline, the
graphic symbol’s animation stops, as well.

1D To add animation to a button’s frame, what type of symbol do you need
to use for the animation?

A movie clip symbol.

1E How do you replace the instance of one symbol with an instance of
another in the main movie or within a symbol?

Select the symbol you want to replace, and click the Swap button in the
Property Inspector.
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Organizing Large Projects

Overview
In this lesson, you will use scenes and labels to organize larger and more
extensive projects. Scenes allow you to divide long complex Timelines into
manageable chunks. Labels let you refer to a frame by a name instead of a
number, making it easier to keep track of critical points in your Timeline,
and making it much easier to refer to those critical frames when using
scripts in Flash.

Objectives
In order to more easily build and organize large projects, you will:

2A Use scenes to organize content in large complex Timelines.

You will section long Timelines using scenes, keeping the Timeline from
becoming unwieldy, and allowing you to build your project in manage-
able portions.

2B Create frame labels.

You will attach labels to frames to mark critical areas in a movie’s
Timeline.

Data Files
Scenes.fla
New Flavors.fla

Lesson Time
30 minutes

LESSON

2
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Topic 2A
Scenes
Many of the projects you will create in Flash will be extensive. Often they will
contain numerous interactive elements and independent animations, In addition, a
Timeline that is built in a single linear fashion can often become unwieldy as it
gets larger.

Flash offers a number of features and tools that allow you to effectively manage
large projects. Scenes provide a way to divide a larger project into more manage-
able chunks. Instead of using one large single Timeline, you can segment a
project into individual scenes.

You will divide a project into several scenes so that you can manage the overall
project more easily. The project you will work with consists of several elements.
First, is an animation using a binoculars mask, followed by the water scene you
created earlier, followed by an opening page where viewers can navigate to vari-
ous pages in a site.

When you have multiple sections in a project, it’s much easier to divide the con-
tent into scenes instead of stringing the content along one Timeline. By using
scenes, you can build sections of your project, allowing you to build the portions
of the project in any order, and make changes to those sections without affecting
the others.

If you did not use scenes, the Timeline’s length would make it unwieldy to
manage. In addition, you will later add interactive elements to the project, allow-
ing you to move to different areas of the main movie. In this case, it is easier to
have the main Timeline move to another scene instead of to a specific frame in
the main Timeline independently.

You will open an existing Flash movie that contains an animated layer mask in a
single scene. You will then add a scene and import content into the new scene.

TASK 2A-1:
Creating Scenes

1. Open the Scenes.fla file inside the Flash MX Level 2 Data folder. This
file’s animation will be the first thing the viewer will encounter in the Flash
movie you are building. Currently, this file has one single scene. You will
rename the scene, and then will add another. To do this, you will use the
Scene inspector. Choose Window→Scene to view the Scene inspector.

Double-click on Scene 1 in the Scene inspector to select its name. Type
Binoculars and press [Enter].
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2. You will now add a second scene. Click the Add Scene button in
the Scene inspector. Change the new scene’s name to Paddling.

3. To move between scenes, you simply click on the scene in the Scene
inspector. Click on the Binoculars scene in the Scene inspector. You are
now viewing the Binoculars scene.

4. Click on the Paddling scene in the Scene inspector. You are viewing the
Paddling scene’s Timeline once again. Next you will copy the paddling
scene’s contents from the Water Scene Flash movie.

5. Open the Water Scene.fla file in the Flash MX Level 2 Data folder.

6. Choose Edit→Select All Frames. All of the frames in the movie, and all
the objects in the frames are selected. Choose Edit→Copy Frames. Close
the Water Scene file without saving the changes.

7. Making sure that the Scenes file is active, and that Paddling is the cur-
rent scene, click on the first frame in the Timeline, and choose Edit→
Paste Frames. Flash pastes the content into the Timeline, and imports the
symbols used into the Library.

8. Save the Scenes file and close it.

Topic 2B
Frame Labels
As you build more complex projects that contain longer Timelines, it is often dif-
ficult to keep track of frame numbers, especially as you change the lengths of
Timelines. For example, you may introduce a new object on frame 150. However,
if you later adjust the Timeline, what was on frame 150 may have moved to a
new frame number. You can add labels to a frame that are attached to that frame,
so even if the frame moves, the label will always be attached, and anything in the
movie that refers to that label.

Additionally, when you are creating scripts within your movies, it’s often easier
to refer to a meaningful name in the script than to a frame number which might
mean little to someone examining or troubleshooting the script. You will now add
labels to the New Flavors.fla file in order to make it easier to later create a
preloader for the file.
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TASK 2B-1:
Adding Labels to a Timeline

1. Open the New Flavors.fla file located inside the Flash MX Level 2 Data
folder. Add a layer called Actions/Labels, and make sure it is the top
layer in the stacking order.

2. You will add a Start label to the first frame in the Timeline. Later, when you
insert frames at the beginning of the Timeline for a pre-loader, the Start label
will consistently mark the beginning of the content currently in the movie.
Click on frame 1 in the Actions/Labels layer. Type Start in the Label
field in the Property Inspector, and press [Enter]. You have labeled frame
1 Start.

3. You will now create another label at the end of the Timeline. When you
want to create a new label, you need to create keyframe. Click on frame
300 in the Labels/Actions layer, and choose Insert→Keyframe. Type End
in the Label field in the Property Inspector. Later, you will use these
labels as you insert a preloader animation into the Timeline.

4. Save the New Flavors file and close it.

Summary
In this lesson, you worked with two techniques to help you manage large
and complex projects: scenes and labels. You added a scene to an existing
movie and imported content into that scene, allowing the movie Timeline to
be divided into sections. In addition, you attached labels to frames in order
to make it easier to refer to critical areas in a Timeline.

Lesson Review
2A How do you create a new scene in a movie?

Click the Add Scene button in the Scene inspector.

2B How do you label a frame in the Timeline?

Select a frame, create a keyframe, and type a label in the Label field in the
Property Inspector.
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Interactivity in Flash

Overview
In this lesson, you will add a number of interactive features to your Flash
movies. You will provide non-linear playback of a movie and basic
interactivity within a movie by adding the Go To, Load Movie, and Get
URL actions to frames and buttons. You will also create more advanced
interactive content including remote rollovers and expanding menus. Finally,
you will create a preloader to ensure smooth playback of larger movies.

Objectives
In order to add non-linear playback and interactive features to your Flash
projects, you will:

3A Provide non-linear playback capability to your Flash movies.

You will attach the Go To and Load Movie actions to frames that have
the movie go to specific frames and scenes in a movie, and to load exter-
nal movies that have already been created.

3B Add more advanced interactive elements to a Flash movie.

You will create animated remote rollovers and custom expanding menus
that will provide attractive and professional interactive elements in your
Flash movies.

Data Files
Scenes.fla
Navigation.fla
New Flavors.fla
history.html
flavors.html
merchandise.html

Lesson Time
2 hours

LESSON

3
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Topic 3A
Basic Playback Control
Up to this point, you have created animations that are generally linear in nature,
that run from start to finish with no interaction from the viewer. However, in
Flash, you can add interactivity to your movies, so that the viewer can control
what goes on within the movie. Flash’s capabilities for interactivity are practi-
cally limitless. You can use Flash to create anything from movies where the
viewer can control playback to advanced games, puzzles, or other applications.

An action in Flash allows for non-linear playback and interactivity that makes
Flash movies more than a linear presentation. You can attach an action to either
an instance of a symbol, or to a frame. For example, you can attach an action to
the instance of a button symbol to have a mouse click on the button send the
viewer to another frame or scene in the movie, or to load a Web page. You can
attach an action to a frame in order to create a working preloader. But this is only
the beginning of what you can do with Flash through actions.

Switching Scenes
You will now connect scenes within the Scenes.fla movie using the Go To action.
You will add a Go To action to a frame to accomplish this. When the Timeline
gets to that frame, the Go To action attached to it will execute.

TASK 3A-1:
Using the Go To Frame Action to Switch Scenes

1. Open the Scenes document located inside the Flash MX Level 2 Data
folder. Choose Binoculars from the Edit Scene drop-down list to view
the Binoculars scene.

2. Next you will add a layer for the actions and any labels you will add later.
Add a new layer called Actions/Labels, and place it at the top of the
stacking order.

3. There is already a keyframe at the end of the scene. However, you need to
add a keyframe to the last frame in the Timeline in the Actions/Labels layer.
In order to add an action or a label to a frame, you should always add a
keyframe to that frame in the correct layer. Add a keyframe to the last
frame of the Timeline in the Actions/Labels layer.

40 FlashMX - Level 2 (Windows)

DO
 N

O
T 

DU
PL

IC
AT

E

In
st

ru
ct

or
 E

di
tio

n



4. Choose Window→Actions to view the Actions palette.

5. You will now add the Go To action to the frame. Making sure the
keyframe you just created is selected, click on the Actions category in
the Actions list to expand the list of available actions within that
category. Click on the Movie Control sub-category to expand it, if
necessary.

6. Double-click on goto in the Actions list. The Go To action is added to
the frame, and the action’s settings now appear.
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7. You will have this frame go to the first frame in the Paddling scene. Choose
Paddling from the Scene drop-down list. Make sure that the value in the
Frame field is 1, and that the Go To And Play radio button is selected.

8. Close the Actions palette. An a marker appears in the frame, indicating that
an action exists on that frame.

9. You have finished adding the Go To action to the frame. You will now pre-
view the movie and see its operation. Press [Ctrl][Enter] to view the
movie. The Preview window appears. The Binoculars scene plays through
once, followed by the Paddling scene. Because the Paddling scene is only
one frame long, you do not see the Paddling animation clearly. You will fix
this in the next task. Close the Preview window.

Loading External Movies
Often complex projects are built in pieces. As you have seen, you can copy
frames, layers, objects, and symbols from one movie to another with relative
ease. However, there may be times when you are working with exported SWF
files, and do not have access to the original FLA files, or you want to have mov-
ies superimposed on each other.

You can load one movie into another using Flash’s Load Movie action. When
you load a movie, the primary movie determines the size of the Stage, the Stage’s
background color, and the movie’s frame rate.

When you use the Load Movie action, you determine its location on the server by
specifying the URL. In addition, you determine its level, which controls whether
or not movies are superimposed on each other.

The main movie is set at level 0. By loading a movie using a higher level, the
loaded movie will play on top of the main movie. However, loading the movie
into level 0 will unload the main movie, replacing it with the loaded movie.

You will have a separate movie load into the Scenes movie. In this case, you will
load the movie so that its Timeline replaces the current movie’s Timeline.
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TASK 3A-2:
Using the Load Movie Action

1. You will add a button to the Paddling scene that you will use to attach the
LoadMovie action. However, you first need to add a Stop action to the
single frame in the Paddling scene to have the playback pause at that frame.
When you add a button to a frame, the main movie needs to stop so that the
viewer can access the button. Choose Paddling from the Edit Scene drop-
down list to view the Paddling scene.

2. Create a new layer called Actions/Labelsand place it at the top of the
stacking order. Because this is the only frame in the scene, there is already
a keyframe by default.

3. With frame 1 in the Actions/Labels layer selected, view the Actions
palette. Double-click on Stop in the Movie Control sub-category in the
Actions category in the Actions list. There are no parameters for the Stop
action, so it is complete.

4. You are ready to add a button to the scene. Create another layer called
Button. Place the Button layer below the Actions/Labels layer in the
stacking order. You are now viewing the button symbol’s Timeline.

5. Create a new button symbol called Land Ho Button.

6. In the Up frame, use the Rectangle tool to create a rectangle that mea-
sures 50 pixels wide by 20 pixels tall, with its center point lined up with
the registration point on the Stage. Fill the rectangle with a solid yellow
color, and remove the stroke.
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7. Create a new layer above the first one, and using the text tool, create a
label for the button with the text Land Ho! Format the text as Arial, 10
point, bold, black. Center the text over the rectangle.

8. You will not create any visual feedback for the button, so you do not have to
add anything for the other button frames. Navigate to the Paddling scene
once again. Click on frame 1 in the Button layer, and place an instance
of the Land Ho Button symbol near the top left corner of the Stage.

9. You will now attach the LoadMovie action to the instance of the button.
Making sure that the Land Ho Button instance is selected, choose
Window→Actions to view the Actions palette, if necessary.

10. You can select the Index category in the Actions list to view all of the avail-
able actions in Flash. The list displays each action name, as well as the
category it resides in. Click on the Index category in the Actions list.

11. Double-click on LoadMovie in the Actions list. The LoadMovie action is
attached to the button instance.

12. You now need to specify the URL of the SWF file that you want to load.
You cannot load native Flash files. Instead, you need to export a Flash file
that you want to use to a SWF file. When specifying the URL of the SWF
file, you can use an absolute or relative URL. In this case, you can simply
type the name of the SWF file since it is located in the same folder as the
current movie. If you do use a relative URL, you need to be sure to maintain
the same file structure when uploading to your Web server in order for the
LoadMovie action to continue to work properly. Type main.swf in the URL
field.
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13. You want the movie level to remain at 0, because you want the main.swf
Timeline to replace the current movie’s Timeline. Make sure that 0
appears in the Location field.

14. Close the Actions palette.

15. Preview the movie, and click the Land Ho! button. When you click the
button in the Paddling scene, the main.swf movie loads.

16. Close the Preview window. Close and save the Scenes file.

Web Navigation Controls
Because your audience will primarily view your Flash content within a Web
browser window, you can use Flash as a dynamic front end for accessing other
Web content, whether it is on your site or on an external site. The Get URL
action allows you to specify an absolute or relative URL, as well as a target win-
dow, letting you control which files appear, and in which browser window those
files appear.

You will add the Get URL action to the buttons you created in the Navigation
document, having those buttons access various HTML files that you will eventu-
ally upload to your Web site.

TASK 3A-3:
Attaching the Get URL Action to a Button

1. Open the Navigation.fla document.

2. Click on the History button instance on the Stage, and choose
Window→Actions.

3. You can access a hierarchical list of actions by holding down the mouse but-
ton on the New Item button(the plus sign). Choose Actions→Browser/
Network→GetURL from the Item drop-down list. The Get URL action is
added, and the parameters for the action appear.
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4. Just as when specifying the SWF in the LoadMovie action, you need to use
the URL that will actually exist when you upload your files to your Web
server. In addition, as with the LoadMovie action, you can use an absolute
or relative URL. You will use a relative URL, and you will export this file
as a SWF into the Website folder, where all of your Web-ready files are
located. Because of this, the relative URL will simply be the name of the
Web page that you want to link to. Type history.html in the URL field.

5. You can also select a target window for the linked URL. In this case, you
want to have the URL open in a new browser window, so that the viewer
can easily close it and return to the movie. Choose Blank from the Win-
dow drop-down list.

6. Attach a Get URL action to the Flavors button that points to the
flavors.html file. Have the URL open in a new window.
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7. Attach a Get URL action to the Merchandise button that points to the
merchandise.html file. Have the URL open in a new window.

8. Because the URLs you used assume the final SWF file will be located in the
same folder as those HTML files, you will save a copy of the Navigation
Flash file in the Website folder, as well. This way, when you test the movie,
the URLs will operate properly. Choose File→Save As. In the Save As dia-
log box, name the file Web Navigation, and place it in the Website folder
inside the Flash MX Level 2 Data folder.

9. You will now test the buttons. Press [Ctrl][Enter] to preview the Flash
movie. The Preview window appears. When you click on one of the buttons,
your Web browser launches, displaying the linked page.

10. Close the Web browser window, and close the Preview window.

Topic 3B
Creating Advanced Navigation Controls
So far you have created simple navigation bars using only standard button
Timelines and simple actions. You will now extend the principles you learned
into creating more complex navigation elements, including animated remote
rollovers and expanding menus.

Using Button Events
As you have worked with buttons so far, you have used a button Timeline itself
to create visual changes in the button based on the contents you have placed in
each frame of the button Timeline.

Additionally, you can use button events to control scripts. However, generally you
will not do this within the button symbol’s Timeline. Instead, you will attach the
script you want to an instance of the button, and select the button event or events
that you want to trigger the script.

When you are actually
creating content for a Web
site, you would not generally
save your native Flash file
inside the folder reserved for
Web content. Instead, you
would publish the file,
placing only the SWF and
companion HTML files in the
Web content’s folder.
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For example, you use a button symbol’s Timeline to create a visual change to the
button when the viewer moves the cursor over it by placing certain contents in
the Over frame. To actually make something additional happen in the main
Timeline when the viewer moves the cursor over the button, you attach a script to
the Over button event for an instance of the button.

It’s important to remember that you generally reserve the contents of the button
symbol’s Timeline only for visual changes to the button. To add interaction in the
movie, you work with an instance of the button.

You will now build a series of remote rollovers using the buttons you created in
the Web Navigation document. While clicking on the button triggers the Get URL
action for each button, you will have additional explanatory messages appear
when the viewer moves the cursor over the button, and disappear when the
viewer moves the cursor away from the button.

You will begin creating the remote rollovers by actually assembling each of the
animated messages that will appear when moving the cursor over each button and
out of the same button. You will use movie clip symbols, because this way, those
animations can play within a single frame of the main movie’s Timeline.

TASK 3B-1:
Creating the Remote Rollover Movie Clip Symbols

1. In order to make it easier to place and edit the remote rollover movie clip
symbols on the Stage, you will place several guides on the Stage. Choose
View→Rulers. Now that you see the rulers, you can add guides to the
Stage. You add a guide by dragging from the rulers.

2. You will create a horizontal ruler guide to line up with the vertical center of
the History button. Position the cursor in the horizontal ruler. Drag down
onto the Stage to create a horizontal guide, and release the mouse but-
ton when the guide lines up with the vertical center of the History
button.

3. Create two more horizontal guides that line up with the vertical centers
of the Flavors and Merchandise buttons.

You can click on a button
instance to view the

registration point to help you
locate the center of an object

when setting a guide.
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4. Create a vertical guide that lines up with the 250 pixel mark on the
horizontal ruler. Choose View→Guides→Lock Guides. The design grid
you created is now locked, so you will not inadvertently move the guides
while you are positioning objects.

5. You will first create the movie clip animation for the History message. Cre-
ate a new movie clip symbol, and name it History Message. You are now
viewing the movie clip symbol’s Timeline. However, in order to build the
animation, it will be easier to see what it looks like in the context of the
main Timeline. To do this, you will use the Edit in Place option.

6. View Scene 1. Drag an instance of the History Message movie clip sym-
bol to the right of the History button, releasing the mouse button when
the top of the arrow cursor lines up with the intersection of the horizon-
tal and vertical guides. Making sure the instance is selected, choose
Edit→Edit in Place. The buttons on the Stage are dimmed. You are viewing
the movie clip symbol’s Timeline, but you are actually able to see the other
elements on the Stage. However, only elements within the movie clip sym-
bol can be edited.

7. Using the Text tool, create a text object on the Stage containing the fol-
lowing text: Click here to find out how Jammin’ Juice got started.Press
[Enter] after the words “out” and “Juice” to create line breaks. Format
the text as Arial, 12 point, bold. Make sure the color is set to black.

8. You will now convert the text to a graphic symbol. While you could build a
motion tween using a standard text object, by creating a graphic symbol, you
make it easier to re-use the animation within the movie clip symbol using
another graphic symbol. Convert the text you just created to a graphic
symbol called History Message Text.

If you can not line up the
movie clip symbol exactly
with the guides using the
mouse, simply use the arrow
keys.
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9. You are ready to use the History Message Text graphic symbol you created
within a motion tween for the History Message movie clip symbol. For the
motion tween, you will have the text move into place from above the Stage,
fading in as it moves. Position the instance of the History Message Text
graphic symbol so that its bottom edge lines up with the top edge of the
Stage. Set the X value in the Info palette to 0.

10. Choose Alpha from the Color drop-down list in the Property Inspector,
and use the Color slider to set the value to 0. You have positioned the
text, and set the transparency to 0 for the initial keyframe in the motion
tween.

11. Next you will create a keyframe for the end of animation. Create a
keyframe in frame 12 of the movie clip Timeline. Making sure that the
keyframe in frame 12 is selected, set the X and Y values of the instance
of the History Message Text graphic symbol to 0. Use the Property
Inspector to set the Alpha value to 100%.

12. You are ready to create the motion tween. Right-click in the Timeline
between the two keyframes, and choose Create Motion Tween from the
shortcut menu. You have completed the motion tween for the History Mes-
sage movie clip symbol.

13. You now need to add a Stop action to frame 12 to keep the movie clip sym-
bol from looping. Normally, you would create a separate layer for actions to
make it easier to troubleshoot the Timeline, but in this case, you will simply
add an action to the keyframe in frame 12 in the layer with the other
content. Click on the keyframe on frame 12, and choose Edit→Deselect
All to make sure no objects are selected. Add a Stop action to frame 12
using the Actions palette.
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14. You will now build the other movie clip symbols to associate with the Fla-
vors and Merchandise buttons by simply duplicating the History Message
movie clip symbol, and altering the duplicates. As you do this, you will see
how using symbols as the building blocks of your projects can really stream-
line your work. Duplicate the History Message movie clip symbol, and
name the duplicate symbol Flavors Message.

To alter the Flavors Message movie clip symbol for use with the Flavors
button, you need to do three things. First, you need to create a Flavors Mes-
sage Text graphic symbol. Then you need move the initial position of the
message object. Third, you need to swap the graphic symbol used in the
animation.

15. You can easily create the Flavors Message Text graphic symbol simply by
duplicating and altering the History Message Text graphic symbol. Duplicate
the History Message Text graphic symbol, and call the duplicate symbol
Flavors Message Text. Double-click on the Flavors Message Text symbol
in the Library palette to view its Timeline. Using the Text tool, change
the text to: Click here to check out our newest flavor creations and your
old favorites. Press [Enter] after the words “out” and “creations” to cre-
ate line breaks.

16. Reset the centerpoint of the text object so its X and Y values are 0. View
the main movie Timeline once again.

17. You will now alter the Flavors Message movie clip symbol. Once again, you
will want to edit in place, so that you can visually position the start of the
motion tween. Delete the instance of the History Message movie clip
symbol. Drag an instance of the Flavors Message movie clip to the
Stage, positioning it to the right of the Flavors button, lining it up with
the intersection of the second horizontal guide and the vertical guide.
Make sure you are lining up the registration point of the instance, and
not the bounding box of the text object within the movie clip. Double-
click on the registration point of the movie clip instance. You are now
editing the Flavors Message movie clip instance in place.

18. You will now alter the initial position of the History Message Text graphic
symbol, and you will then swap it with an instance of the Flavors Message
Text symbol.Click on frame 1 in the Timeline, and click on the instance
of the History Message Text graphic symbol on the Stage. Position the
instance of the History Message Text graphic symbol so that its bottom
edge lines up with the top edge of the Stage. Set the X value in the Info
palette to 0. Click Swap in the Property Inspector. In the Swap Symbol
dialog box, select Flavors Message Text from the symbol list and click
OK.

19. Click on frame 12 in the Timeline, and click on the instance of the His-
tory Message Text graphic symbol. Swap it with the Flavors Message
Text symbol. The movie clip animation is complete.
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20. Finally, you will use the above steps to create Merchandise Message movie
clip symbol, along with a Merchandise Message Text graphic symbol. Dupli-
cate the History Message Text graphic symbol. Name the duplicate
Merchandise Message Text. Change the text in the symbol to the follow-
ing: Click here to check out our latest Jammin’ Juice hats, beach towels,
and coolers. Press [Enter] after the words “out” and “Juice” to create
line breaks.

21. Duplicate the History Message movie clip symbol. Name the duplicate
Merchandise Message. View the main movie Timeline. Delete the
instance of the Flavors Message movie clip symbol. Place an instance of
the Merchandise Message movie clip symbol on the Stage, lining up its
registration point with the intersection of the bottom horizontal guide
and the vertical guide.

22. Edit in place, and position the text object in the frame 1 so its bottom
edge lines up with the top edge of the Stage. Use the Property Inspector
to swap the History Message Text graphic symbol instances in frames 1
and 12 with the Merchandise Message Text graphic symbol.

23. Because you only placed the instances of the movie clip symbols on the
Stage to help you position the animations within those symbols, you will
remove the instances from the Stage.View the main movie Timeline.
Remove any of the message movie clip instances from the Stage.

24. Save the file.

Remote Rollovers
Now that you have created the objects you will use for the remote rollovers, you
will now set up the rollovers using various actions assigned to button events.

To have the remote rollover movie clips appear based on the mouse events, you
will create several additional keyframes. Each frame will contain one of the
remote rollover movie clips. Additionally, you will add Stop actions to the frames
so that the main movie Timeline pauses on that frame, allowing movie clip
instances to play through.
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TASK 3B-2:
Setting up Remote Rollovers Using Button Events

1. You will have a separate layer for frame labels and actions in the Timeline,
and one for the rollover movie clips. Keeping things in separate layers
makes it much easier to troubleshoot when building a complex Timeline.
Create two new layers. Name the top layer Labels/Actions. Name the
middle layer Remote Rollovers. Name the original layer 1 Buttons.

2. You will begin by creating a Stop action on frame 1. You need to do this,
because the movie needs to pause on frame 1 so the viewer can access the
rollover buttons. Click on frame 1 in the Labels/Actions layer, and choose
Window→Actions to view the Actions palette. Choose Edit→Deselect All
to make sure that no objects are selected.

3. Add a Stop action to the frame.

4. You will now add another keyframe in the Labels/Actions layer. You will
label the frame, and add a Stop action to it, as well. Add a keyframe to the
Labels/Actions layer in frame 2. Type HistoryOver in the Label field in
the Property Inspector. Add a Stop action to the frame.

5. Add a keyframe to frame the Labels/Actions layer in frame 3. Label the
frame FlavorsOver. Add a Stop action to the frame.

6. Add a keyframe to frame the Labels/Actions layer in frame 4. Label the
frame MerchOver. Add a Stop action to the frame.

7. You will also add keyframes to the Remote Rollovers layers. Remember that
whenever you are changing the contents of a layer from one frame to
another, you should add a keyframe. You will have a different movie clip in
each of the keyframes in the Remote Rollovers layer, and a different action
assigned to the buttons in each frame of the Buttons layer. Add keyframes
to frames 2, 3, and 4 in the Remote Rollovers layer.

8. Now that the keyframes are set up, you can add the appropriate movie clip
instances to each of the keyframes. In the Remote Rollovers layer of
frame 2, add an instance of the History Message movie clip symbol.
Position its registration point at the intersection of the vertical guide and
the top horizontal guide.

9. In the Remote Rollovers layer of frame 3, add an instance of the Flavors
Message movie clip symbol. Position its registration point at the inter-
section of the vertical guide and the second horizontal guide.

10. In the Remote Rollovers layer of frame 4, add an instance of the Mer-
chandise Message movie clip symbol. Position its registration point at
the intersection of the vertical guide and the bottom horizontal guide.
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11. You are now ready to create the button events to trigger the rollovers. How-
ever, you will remove the existing actions from the buttons in frame 1,
because you will assign those actions in other keyframes.Move the
playhead to frame 1, and click on the History button to select it. Make
sure no other objects are selected, and choose Window→Actions if the
Actions palette is not visible.

12. Click on the onRelease line in the History button script in the Actions
palette, and click the Delete Action button. There are now no actions cur-
rently attached to the History button.

13. Remove the getURL item from the Flavors and Merchandise buttons in
frame 1.

14. Next you will create keyframes in frames 2, 3, and 4 in the Buttons layer, so
that you can assign various actions to each frame’s button set. By creating
keyframes in advance of adding scripts to the buttons, you are creating a
separate series of buttons for each keyframe. Add keyframes to frames 2,
3, and 4 in the Buttons layer.

15. You will now add a Go To action to the History button in frame 1, triggered
when the viewer moves the cursor over the button. You want the Go To
action to move the playhead to the HistoryOver frame which contains the
History Message movie clip. Move the playhead to frame 1, and click on
the History button to select it. Make sure no other objects are selected.
Hold down the mouse button on the Add Item button in the Actions
palette. A drop-down list appears, allowing you to select an action. Choose
Actions→Movie Control→GoTo from the Item drop-down list. The
parameters of the Go To action appear. Choose Frame Label from the
Type drop-down list. Choose HistoryOver from the Frame drop-down
list.
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16. The default mouse event for a Go To action attached to a button is Release,
which occurs when the viewer clicks on the button, and then releases the
mouse button. In this case, you want the Go To action triggered by the
RollOver mouse event. Click on the on (release) line (just above the
gotoAndPlay line in the script) to select it. You now see the various mouse
events that you can attach to the item in the script. Uncheck the Release
checkbox, and check the Roll Over checkbox.

You have changed the mouse event associated with the action.

17. Next you will set up what happens when the viewer clicks on the button.
You will use the Get URL action to have a Web page open in a new
window. However, you will attach this action to the button in the
HistoryOver frame, which is where the playhead currently would be in the
Timeline. Click on the keyframe in the Buttons layer of frame 2. Click
on a blank area of the Stage to deselect all items, and click on the His-
tory button to select it. Choose Actions→Browser/Network→GetURL
from the Item drop-down list in the Actions palette. Set the URL to
history.html. Choose Blank from the Window drop-down list. Make sure
the mouse event is set to Release.
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18. You will also add another action to the script for the History button in this
frame. When the viewer rolls away from the button, or releases the button,
you want to return to the first frame in the Timeline. This way, the naviga-
tion bar resets. Making sure that the keyframe in the Buttons layer of
frame 2 is still selected, and that the History button is still selected, click
on a blank area in the script window in the Actions palette. You want to
make sure you are adding a completely new action, and not attaching an
action to the same mouse event. Use the Item drop-down list to add a Go
To action which goes to frame 1. Set the action to trigger on both the
Release and Roll Out events.

19. You will now set up the actions for the Flavors button. Click on the
keyframe in the Buttons layer of frame 1, and select the Flavors button.
Make sure no other objects are selected. Add a Go To action to go to the
frame labeled FlavorsOver, triggered by the RollOver mouse event.
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20. Click on the keyframe in the Buttons layer of frame 3 (the FlavorsOver
frame), and select the Flavors button. Add a Get URL action to the Fla-
vors button. Set the URL to flavors.html and choose Blank from the
Window drop-down list. Make sure the mouse event is set to Release.

21. Add a Go To action which goes to frame 1. Set the action to trigger on
both the Release and Roll Out events. Make sure the Go To action is not
linked to the same mouse event as the Get URL action.
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22. You will now set up the actions for the Merchandise button. Click on the
keyframe in the Buttons layer of frame 1, and select the Merchandise
button. Add a Go To action to go to the frame labeled MerchOver, trig-
gered by the RollOver mouse event.

23. Click on the keyframe in the Buttons layer of frame 4 (the MerchOver
frame), and select the Merchandise button. Add a Get URL action. Set
the URL to merchandise.html and choose Blank from the Window drop-
down list. Make sure the mouse event is set to Release.

24. Add a Go To action which goes to frame 1. Set the action to trigger on
both the Release and Roll Out events. Make sure the Go To action is not
linked to the same mouse event as the Get URL action.

25. You will now save the file inside the Website folder, and then test the movie.
Choose File→Save As. Name the file Advanced Web Navigation, and
save it inside the Website folder inside the Flash MX Level 2 Data
folder. Preview the movie. Flash creates a SWF file inside the Web folder.
Move the cursor over each of the buttons, and click on each of them.

26. Return to Flash. Close the Preview window. Close the
Advanced Web Navigation file.

58 FlashMX - Level 2 (Windows)

DO
 N

O
T 

DU
PL

IC
AT

E

In
st

ru
ct

or
 E

di
tio

n



Expanding Menus
You can create even more elaborate navigation controls by combining buttons and
movie clips. By using the Track as Menu Item option, you can use button and
movie clip symbols to assemble expanding menus, providing an elegant interface
for your viewers to interact with the Flash content.

You will create an now create an expanding menu that you could use for naviga-
tion to other areas of your Flash movie or to access external Web pages.

TASK 3B-3:
Creating an Expanding Menu

1. Create a new Flash file.

2. Create a new button symbol named Flavors Menu Button.

3. In the Up frame of the Flavors Menu Button Timeline, use the text tool
to create a “Flavors” text label. Format the label as Arial, 18 point,
bold, black text. Position the label so its center lines up with the regis-
tration point.

4. Create a keyframe in the Over frame. Change the text for the Over
frame to red.

5. The contents of the Hit frame in a button determine the hot area of the but-
ton, which is the area that actually responds to mouse events. When a button
consists only of text, the spaces between the characters and within the char-
acters themselves would make it more difficult for the viewer to interact with
that button, because wherever a space exists, the button would not react to a
mouse event. By placing an object in the Hit frame, you control what area of
the button is interactive. You will add a rectangle that surrounds the text
labels in the Up and Over frames, so the entire area of the text will react to
mouse events. Create a keyframe in the Hit frame. Draw a rectangle
filled with a solid color the size of the bounding box around the text,
and remove the stroke. It doesn’t matter what color the fill of the shape is
in the Hit frame, as long as it’s a solid color. Drag the text object from
under the rectangle shape, and delete it. Make sure the center of the
rectangle lines up with the registration point.

6. You will now create the actual expanding menu movie clip. Create a new
movie clip symbol, and name it Flavors Menu.

7. In the Flavors Menu movie clip symbol’s Timeline, create two additional
layers. Name the top layer Labels/Actions, the middle layer Menu, and
the bottom layer Menu Close.

8. There are already keyframes in frame 1 by default. You will also create
keyframes in frame 2 for each of the layers. Create keyframes in frame 2
for all three layers.

9. Next you will label the keyframes, so it will be easier to set up the actions
you will use. Create a label in the Labels/Actions layer in frame 1 called
Hide.
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10. Create a label in the Labels/Actions layer in frame 2 called Show.

11. Place a Stop action in frames 1 and 2 in the Labels/Actions layer.

12. Select the keyframe in the Menu layer in frame 1. Add an instance of
the Flavors Menu Button to the Stage, and line up its center point with
the registration point on the Stage.

13. With the Flavors Menu Button instance selected, choose Track as Menu
Item from the Track menu in the Property Inspector.

14. You will now duplicate the Flavors Menu Button symbol several times, and
then alter the text within it. This will allow you to quickly build the items in
the sub-menu. Duplicate the Flavors Menu Button symbol in the Library
window. Name the duplicate symbol Mango Tango. View the Mango
Tango button symbol’s Timeline. Change the text objects in the Up and
Over frames of the Mango Tango symbol to Mango Tango and make
sure the text lines up with the registration point. Adjust the rectangle in
the Hit frame to match the size of the Mango Tango text. (Hint: You can
view the width and height of the text object in the Up or Over frame
using the Info palette, and enter those values for the Hit frame.

15. Create another duplicate of the Flavors Menu Button symbol called
Grape Escape. View the Grape Escape button symbol’s Timeline. Change
the text objects in the Up and Over frames of the Grape Escape symbol
to Grape Escape and make sure the text lines up with the registration
point. Adjust the rectangle in the Hit frame to match the size of the
Grape Escape text.

16. Create one more duplicate of the Flavors Menu Button symbol called
Apple vs Orange. View the Apple vs Orange button symbol’s Timeline.
Change the text objects in the Up and Over frames of the Apple vs
Orange symbol to Apple vs Orange and make sure the text lines up with
the registration point. Adjust the rectangle in the Hit frame to match the
size of the Apple vs Orange text.

17. You will now assemble the expanded menu. View the Flavors Menu movie
clip symbol’s Timeline. Select the keyframe in the Menu layer in frame
2. Add an instance of the Flavors Menu button to the Stage, lining up its
center point with the registration point.

18. Add instances of the Mango Tango, Grape Escape, and Apple vs Orange
symbols to the Stage, positioned as shown. Make sure there is no space
between the bounding boxes of the instances. You can [Shift]-click on the
menu items to view their bounding boxes, to make sure that the symbol
instances line up, and that there is no space between the instances. This will
be critical for the proper functioning of the menu.
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19. You have finished creating the expanded menu. Next you will set up the
menu so it will close. Select the keyframe in frame 1 of the Menu layer.
Select the Flavors Menu Button instance, and add a Go To action that
goes to the Show label. Have the action triggered by the Roll Over
mouse event.

20. Select the keyframe in the Menu Close layer in frame 2. Draw a rect-
angle that surrounds the entire expanded menu. Make sure that the
rectangle is filled with a solid fill color, and remove the stroke around
the rectangle.

21. Select the rectangle, and convert it to a button symbol named Close
Menu. View the Close Menu button symbol’s Timeline.

22. You will only set up a Hit frame for the button to have it act as a trigger.
Select the filled rectangle in the Up frame of the button and choose
Edit→Cut. Create a keyframe in the Hit frame, and choose Edit→Paste
in Place. Now the only content of the button is in the Hit frame. This cre-
ates an invisible button.

23. View the Flavors Menu movie clip Timeline, once again. Select the
instance of the Close Menu button symbol in the Close Menu layer in
frame 2. Choose Track as Menu Item from the Track drop-down list in
the Property Inspector.
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24. With the Close Menu button instance still selected, add a Go To action
to go to the Hide label. Set the mouse event that triggers the action to
Roll Over.

Because the Menu Close instance is in a layer below the menu item button
instance, the button instances above will block the Roll Over event in the
Close Menu button from occurring unless the viewer rolls over a portion of
the Close Menu rectangle that isn’t covered by one of the menu items.

25. Finally, you will add a Get URL action to each of the buttons in the
submenu. You will have each button link to an image in the browser
window. The images are located inside the flavors folder, inside the Website
folder. When you save and publish the file, the SWF will be inside the
Website folder. So to access the flavors images, you need to use the relative
URL, which includes the flavors directory. Select the Mango Tango menu
button. Attach a Get URL action to the button. Type flavors/
mangotango.jpgin the URL field in the Actions palette. Choose Blank
from the Window drop-down list. Have the action triggered by the
Release mouse event.

26. Attach a Get URL action to the Grape Escape button instance. Type
flavors/grapeescape.jpgin the URL field in the Actions palette. Choose
Blank from the Window drop-down list. Have the action triggered by
the Release mouse event.

27. Attach a Get URL action to the Apple vs Orange button instance. Type
flavors/orangevsapple.jpgin the URL field in the Actions palette. Choose
Blank from the Window drop-down list. Have the action triggered by
the Release mouse event.

28. Save the file. Name it Menu.fla and place it in the Website folder inside
the Flash MX Level 2 Data folder.

29. You will now place an instance of the Flavors Menu movie clip symbol on
the Stage.View the main movie Timeline. Drag an instance of the Flavors
Menu movie clip symbol to the Stage. Save the file, then preview the
movie, and test the menu.

30. Close the Menu document.
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Preloaders
The export format for Flash, SWF, is a streaming file format. The contents of
each frame in the movie are downloaded to the viewer’s computer sequentially.
What this means is that the file can begin playing before the entire file is
downloaded. While streaming is an advantage, sometimes interruptions in play-
back can occur. If the file is being streamed, and a frame is encountered that
contains a lot of data (a bitmap graphic or a sound, for example), the playback
will stall while that information is downloaded.

In order to ensure smooth playback, often Flash designers often specify that a
certain portion of the file load before playback begins. The easiest way to do this
is to use an If Frame is Loaded action. With this action, you can specify that
frames containing the most data load completely before playback of the file
begins.

Larger SWF files can take significant time to download, especially with slower
dial-up connections. Because the If Frame is Loaded action prevents the file from
beginning playback until certain frames are completely downloaded, without a
preloader, the viewer will be waiting with no indication that anything is
happening. This is why many Flash designers create a preloader animation in
conjunction with the If Frame is Loaded action, to let the viewer know that the
file is downloading.

You will use the preloader sequence that you created earlier in conjunction with
the If Frame is Loaded action to make sure that a large file plays back smoothly.
You will work with the New Flavors.fla file, which contains background music
and several background graphics. Because the file is so large, those viewers using
low bandwidth connections could potentially experience interrupted playback.
Therefore, you will create a preloader sequence, and use the If Frame is Loaded
action to make sure that playback doesn’t begin until the last frame of the movie
is loaded.

TASK 3B-4:
Creating a Preloader

1. Open the New Flavors.fla file located in the Flash MX Level 2 Data
folder. Earlier you created a layer for actions and labels. You placed a Start
label at that first frame in the Timeline, and an End label in the last frame.

2. You will now insert an additional frame that will contain the preloader.
Because the preloader is a movie clip symbol, it will only need one frame to
run, since its animation is independent of the main Timeline. Choose Edit→
Select All Frames. Position the cursor on one of the selected frames, and
drag to the right one frame.

Flash inserts a blank keyframe in frame 1 of all of the layers. In addition,
the labels moved along with the existing frames, so the Start label now
refers to frame 2, and the End label refers to frame 301.
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3. Select the keyframe in frame 1 of the Labels/Actions layer, and add a
Preloaderlabel.

4. Next you will import the preloader animation from the Preloader Flash file.
Choose File→Open as Library, and select the Preloader file, located
inside the Flash MX Level 2 Data folder.

5. Select the keyframe in frame 1 of the Flavors layer. Drag an instance of
the Loading Animation movie clip symbol from the Preloader Library
palette to the Stage. All of the symbols associated with the preloader ani-
mation are imported into the New Flavors file.

6. You will now set up the preloader. To do this, you will have the Loading
Animation movie clip symbol continue playing until the last frame in the
Flavors scene loads. You do not want the Timeline to go to the Start label
until the last frame in the Timeline is loaded. You will create a script to
check to make sure the last frame of the movie is loaded before moving to
the Start label. Select the keyframe in frame 1 of the Labels/Actions
layer. View the Actions palette.

7. Choose Actions→Conditions/Loops→If from the Actions drop-down list.

You have added the If command. The Condition field is now available.

8. Choose Properties→_framesloaded from the Actions drop-down list. The
text _framesloaded is added to the Condition field. You want the condition to
specify that the last frame in the movie is loaded.

When using labels to build a
preloader it is easier to use

the if Frame is Loaded
action, since you can refer to

frame labels within the
action’s parameters.

However, the action is being
deprecated after Flash 6, so

you should generally use the
framesloaded property

instead.
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9. Choose Operators→Comparison Operators→>= from the Actions drop-
down list. Choose Properties→_totalframes from the Actions drop-down
list.

You have completed the condition statement. Next you will specify what
happens if the condition is true. If the frames loaded is at least equal to the
total frames in the movie (in other words, the entire movie is loaded), you
want the playhead to begin playing at the Start label.

10. Choose Actions→Movie Control→goto from the Actions drop-down list.
Choose Frame Label from the Type drop-down list. Choose Start from
the Frame drop-down list. Make sure the Go to and Play radio button is
selected.

11. You have completed the pre-loader. In order to test it, you will test the
movie, as you have done before. However, because the file currently resides
on your hard disk, simply testing the movie would load the entire file imme-
diately, and you wouldn’t be able to see if the preloader is working correctly.
In order to see the preloader actually working, you need to simulate an
actual slow download, which you can do while testing the movie. Choose
Control→Test Movie. The movie begins playing immediately. You will
simulate a slower download.
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12. Choose Debug→56K. Choose View→Show Streaming. You now see the
preloader running while the movie downloads, as it would if you were using
a 56K connection.

13. Close the Preview window and save the New Flavors file.

Summary
In this lesson, you provided the ability for your movies to play in a non-
linear fashion. Next you created simple navigation controls that allowed the
viewer to move to various parts of a movie or to external Web resources.
You then created advanced interactive elements, including animated remote
rollover, and expanding menus. Finally, you created a preloader sequence
that provided smooth playback for large Flash files over slow connections.

Lesson Review
3A What action do you use to have a movie move from one scene to

another?

You use a Go To action, specifying that the movie goes to the new scene.

3B Which action do you use to allow the user to access external Web pages
from inside your Flash movie?

The Get URL action.
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Working with Sound

Overview
In this lesson, you will import sounds into a movie, and will add sounds
movie clip and button Timelines. You will then edit and apply effects to
sounds to fine tune them for your project.

Objectives
In order to work with sound in your projects, you will:

4A Import sounds into a project.

You will import sounds into your movies and add those sounds to frames
in the main movie Timeline, and to frames in button and movie clip sym-
bol Timelines.

4B Work with sound properties.

You will work with sound properties, edit your sounds, and apply fade
effects to fine-tune sounds for your projects.

Data Files
Scenes.fla
Advanced Web
Navigation.fla
Calypso.mp3
Paddle.wav
Pour.wav

Lesson Time
45 minutes

LESSON

4
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Topic 4A
Importing Sounds
Adding sound to a Flash movie can create professional flair to your presentation,
giving the viewer a more immersive experience with the content of your movie.
There are many ways you can integrate sound into your projects. You can have
short sounds attached to buttons to give the viewer feedback as they are navigat-
ing through your content. Further, you can create background sounds or
soundtrack music. You can even layer narration into your movies.

In order to add a sound to your movie, you need to import it into the Flash file.
You can then add the sound to a frame. You will begin by opening the Scenes.fla
file. You will import a sound into the file that you will eventually use with the
paddling animation.

TASK 4A-1:
Importing Sounds and Adding Them to the Timeline

1. Open the Scenes.fla file located inside the Flash MX Level 2 Data folder,
and view the Paddling scene.

2. You will now add the Paddling sound to the movie, and will place the sound
in the Timeline. Choose File→Import. The Import dialog box appears.
Select the Paddle.wav file inside the Sounds folder inside the
Flash MX Level 2 Data folder, and click Open.

3. View the Library. The Paddle.wav file has been added to the Library. You
will now place it in the Paddling scene. However, you want it to be part of
the Paddling movie clip symbol so that it will play along with each repeti-
tion of the looping movie clip.

4. Double-click on the Paddling movie clip symbol in the Library window
to open its Timeline.

5. Create a new layer in the Paddling Animation Timeline called Sound,
and make sure that it is the top layer.

6. Click on frame 1 in the Sound layer, and drag the Paddle.wav file from
the Library window to the Stage. Release the mouse button anywhere on
the Stage.

The sound is added to the Timeline.

When you are adding a sound to the Timeline, you do not have to place the
sound in any particular place on the Stage. You have added the sound to the
Timeline. However, to hear its effect, you need to preview the scene.
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7. Click on the Paddling scene in the information bar. Choose Control→
Test Scene. The Paddling animation loops, with the sound playing once each
time the movie clip loops.

8. Close the Preview window. Close and save the Scenes movie.

Button States with Sound
In the previous task, you added a sound to the beginning of a Timeline so that it
played during the playback of the movie clip symbol instance’s Timeline. How-
ever, you can also associate sounds with frames in button states in order to
enhance the effect of a navigation bar.

You will assign a sound to the Over state of the buttons in the
Advanced Navigation.fla file.

TASK 4A-2:
Associating Sounds with Frames

1. Open the Advanced Web Navigation.fla file located in the Website folder,
inside the Flash MX Level 2 Data folder.

2. You will begin by adding the Pour sound to the Over state of the History
Button symbol. When assigning sounds to a button frame, you need to work
with the actual button symbol, and not an instance of a button. Double-click
on the History Button symbol in the Library palette to open its
Timeline.

3. Create a new layer called Sounds, and make sure it is the top layer.

4. Create a keyframe in the Over frame of the Timeline in the Sounds
layer.

5. Choose File→Import. In the Import dialog box, select the Pour.wav
sound inside the Sounds folder inside the Flash MX Level 2 Data folder.
The Pour sound is added to the Library.

6. Making sure the Over frame is selected in the Sounds layer, drag the
Pour sound to the Stage.
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7. Choose Event from the Sync drop-down list in the Property Inspector, if
necessary.

8. Using the above steps, add the Pour sound to the Over state of the Fla-
vors and Merchandise buttons.

9. You will now preview the movie. Press [Ctrl][Enter] to test the movie.
Move the cursor over each button. As you move the cursor over each but-
ton, the Pour sound plays in its entirety. You would like the Pour sound to
stop when the viewer moves the cursor away from a button. You will fix that
in the next task.

10. Close the Preview window. Save the file.

Topic 4B
Event vs. Streaming Sounds
There are two basic types of sounds in Flash: event sounds and streaming sounds.
Event sounds must be entirely downloaded before they can begin playing, while
streaming sounds can begin playing as soon as there is enough information for
the sound to begin playing.

Further, event and streaming sounds differ in how they play back within the
Timeline. Streaming sounds are designed to be synchronized with the Timeline,
but event sounds play independently of the Timeline. An event sound will play
through its entire duration until it is specifically told to stop.

Finally, event and streaming sounds differ in their intended use. You use event
sounds for short sounds associated with events like button states. You use stream-
ing sounds for longer sounds like background music and narration.

You will now add background music to the Advanced Navigation movie. In addi-
tion, you will set up the buttons so that the Pour sound stops playing when you
click a particular button.

TASK 4B-1:
Controlling Event and Streaming Sounds

1. Import the Calypso sound located in the Sounds folder inside the
Flash MX Level 2 Data folder.

You will have the Calypso sound play as background music. However, you
can’t simply place the sound on the first frame of the Timeline. The reason
why is that a streaming sound must actually have enough frames in the
Timeline to play. Since there is a Stop action in the first frame to keep the
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buttons visible, only one frame of the music would actually play. The solu-
tion to this is to place the Calypso sound inside its own movie clip symbol,
which you can then place on the first frame in its own layer. Remember that
a movie clip symbol plays independently of the main Timeline, so as long as
there is nothing specifically stopping the movie clip symbol from playing or
being removed from the Timeline, it will play in its entirety.

2. Create a new movie clip symbol called Music. View the Music movie clip
symbol’s Timeline.

3. With frame 1 selected, drag the Calypso sound file from the Library
palette to the Stage.

4. Next you need to set the Sync option to Stream. With frame 1 selected in
the Timeline, choose Stream from the Sync drop-down list in the Prop-
erty Inspector. The Stream option allows the sound to start playing before it
is fully downloaded. This is usually the best option to use when the sound is
not associated with a particular event in the Timeline.

5. Next you need to extend the Timeline of the movie clip symbol out so there
are enough frames for the entire music clip to play. Click on frame 305,
and choose Insert→Frame. The movie clip’s Timeline is extended approxi-
mately to the length of the music clip.

6. You will now place an instance of the Music movie clip on the main
Timeline. View the main movie Timeline. Create a new layer called
Music. Making sure that frame 1 of the Music layer is selected, drag an
instance of the Music movie clip symbol to the Stage.

7. Test the movie. The background music plays. As you movie the cursor over
each button, the Pour sound plays. However, when you click on a button, the
Pour sound does not stop playing. You will now fix this by working with the
Down frame in the Bottlecap button symbol. Close the Preview window.

8. You will begin by changing the History Button symbol. Open the History
Button symbol’s Timeline. Add a keyframe to the Down frame of the
Sound layer.

9. In the Property Inspector, choose Pour from the Sound drop-down list.
Choose Stop from the Sync drop-down list.

Now when you click on a button, the Pour sound will stop playing.

10. Using the above steps, add the Stop sync option for the Pour sound to
the Down frame of the Flavors and Merchandise buttons.
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11. Preview the movie once again, and test the buttons. The sounds in the
movie all now work properly. The background music plays. When you move
the cursor over a button, the Pour sound plays. When you click on a button,
the Pour sound stops playing.

12. Close the Preview window and save the file.

Sound Editing
Flash contains a number of editing tools that allow you to edit the actual sound
wave form and add effects such as fades to sounds. These features allow you to
fix and fine-tune sounds for your movie, and repurpose the same sounds for dif-
ferent functions in the movie.

If you want the edit of a sound to be universal to all uses of the sound in the
movie, you would edit the original imported sound in the Library. If, instead, you
want an edit to only apply to a particular instance of the sound, you would use
the Property Inspector with a selected sound instance.

You will edit the Pour sound to eliminate the silence at the beginning and end of
the sound. In addition, you will lower the relative volume of the Calypso music
so it doesn’t overwhelm the Pour sound as you roll over buttons. In both of these
cases, you will edit the instance of the sound.

TASK 4B-2:
Editing Sounds

1. Open the History Button symbol’s Timeline. Click in the Over frame in
the Sound layer. The sound properties are now available in the Property
Inspector.

2. Click Edit in the Property Inspector. The Edit Envelope dialog box
appears.
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3. Drag the Time In control to the .25 second mark in the Timeline. Drag
the Time Out control to the 3.45 second mark in the Timeline. Click the
Play button to hear the edited sound.

Click OK. You have edited only this instance of the sound. The original
imported sound in the Library has not been affected, so if you place another
instance into the movie, it will not be edited.

4. Next you will reduce the volume of the Calypso music. In order to do this,
you need to open the Music movie clip symbol which contains the Calypso
sound. Open the Music movie clip symbol in the Library to view its
Timeline.

5. Click on the first frame of the Timeline. The sound settings are now avail-
able in the Property Inspector. Click Edit.

6. Drag the left channel envelope handle down until it is approximately 1⁄4
inch above the zero line. Repeat the same step for the right channel
envelope handle.

Click the Play button. The sound’s volume is now reduced. Click OK.

Drag the vertical bar as
shown in the following
graphic to change the Time
In and Time Out controls.
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7. Test the movie. The background music volume is now lower, and there is
no delay in the Pour sound when you move the cursor over the History
button.

8. Close the Preview window. Close and save the
Advanced Web Navigation file.

Summary
In this lesson, you learned to import sounds into your movies and place
those sounds in the Timeline. You added sounds both to standard animations
and to button events. In addition, you edited sound length and volume in
order to fine-tune each sound for your project.

Lesson Review
4A If you want a sound to play when the viewer clicks on a button, what do

you do?

You need to import the sound, and add it to the Down frame in the button
symbol’s Timeline.

4B How do you lower the volume of a sound in the Timeline?

Select the frame that contains the sound, and click the Edit button in the
Property Inspector. In the Edit Envelope dialog box, drag the envelope
handles down.
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Testing and Publishing a
Flash Movie

Overview
In this lesson, you will test the download performance of a movie, and will
identify the ways that you can reduce the file size and resulting download
times of your project. You will then work with various publishing options to
optimize your movie for its intended audience.

Objectives
In order to best prepare your Flash movies to be distributed, you will:

5A Evaluate download performance.

You will test the download performance of a Flash movie and identify
potential ways to reduce the size of your movies.

5B Identify ways to reduce file size and download time in your movies.

You will identify the factors that lead to larger file sizes, and how you
can optimize your movies to reduce file size and download times.

5C Export and publish Flash movies to prepare them for viewing by
your audience.

You will use export and publish settings to adjust your movies so that
they are optimized for your target audience.

Data Files
Scenes.fla

Lesson Time
45 minutes

LESSON

5

Lesson 5: Testing and Publishing a FlashMovie 75

DO
 N

O
T 

DU
PL

IC
AT

E

In
st

ru
ct

or
 E

di
tio

n



Topic 5A
Evaluating Download Performance
When a Flash movie is played in the viewer’s browser, the Flash Player attempts
to use the frame rate you set for the movie. However, due to the speed of the
viewer’s computer, and the speed of the viewer’s Internet connection, the actual
frame rate during playback can vary. As you learned before, if a movie that is
downloading reaches a particular frame before the frame’s required data has com-
pletely downloaded, the movie pauses until enough data arrives to continue.

In an earlier lesson, you built a simple preloader by testing to see if a particular
frame has downloaded. In that case, you specified that all of the frames should
download before the movie plays. However, this doesn’t always need to be the
case. Many times, the largest content may occur somewhere else in the movie.

By using the Bandwidth Profiler, you can see how much data is sent for each
frame according to the modem speed you specify. When the Bandwidth Profiler
simulates the downloading speed, Flash estimates of typical Internet performance
produced by that speed. This allows you to fairly accurately test the movie You
should attempt to test your movie at each speed you intend to support, and on
each computer you intend to support. This allows you to make sure the content
works well using the slowest connection and computer it is designed for (i.e.
without needing to constantly upload it to a Web server).

In addition, you can have Flash generate a report of frames that are slowing
playback. This allows you to see where you can optimize your movie to eliminate
the bottlenecks.

You will now test the Scenes movie in order to check for any potential playback
problems. In addition, you will check if there are certain elements in the movie
that lead to its increased file size.

TASK 5A-1:
Using the Testing Environment

1. Open the Scenes.fla file located inside the Flash MX Level 2 Data folder.

2. You will begin by testing the movie. Choose Control→Test Movie. Flash
creates a SWF file, and displays the movie in a Preview window.

As you learned before when inserting a preloader into a file, when you pre-
view a movie from the Flash file located on your local hard disk, the movie
loads so quickly that you can’t tell simply by previewing how playback will
behave for your viewer who is downloading the file over the Internet. How-
ever, once you are in the testing environment, you can set a simulated
download speed and view the movie as it would perform using the selected
speed.
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3. Choose Debug→56 Kbps. Choose View→Show Streaming. The movie
now performs as it would if it were being downloaded using a 56K
connection. There is a delay between each of the scenes. In this case, you
would most likely set up a preloader, since the content needs to preload in
order for uninterrupted playback to occur.

4. You can also view a Streaming graph to allow you to see the streaming
behavior of the movie. This is one tool you can use to isolate areas of the
movie that are affecting playback. Choose View→Bandwidth Profiler.
Choose View→Streaming Graph, if necessary.

The Streaming graph shows where there are potential problems with play-
back will occur. Given the download speed you selected in the Debug menu,
the Streaming graph displays how the movie is streaming. Each bar is a
frame. Note that the first bar is above the red line. This means that there is
more data that must be streamed before that frame can actually play back.
The remainder of the frames are below the red line, indicating that the
streaming will fairly quickly catch up with playback. However, at around
frame 97, the streaming bar is above the red line again, indicating an inter-
ruption in playback.

5. In addition to the Streaming graph, you can use the Frame by Frame graph,
which allows you to quickly see which frames contain the most data, and
which might cause the most problems. Choose View→Frame by Frame
Graph.

In the Frame by Frame graph, if any of the frames extends beyond the red
streaming line, this indicates that the frame could potentially cause playback
interruptions, because the entire frame must download before it plays. Note
that most of the content must load at frame 1 and frame 97. In this case,
again, you might want to create a preloader to make sure that the content in
frame 97 is loaded before playback begins. Close the Preview window.
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6. Finally, you can generate a report that summarizes the data size for the final
Flash Player file. Choose File→Publish Settings. The Publish Settings dia-
log box appears. Click on the Flash tab, and check the Generate Size
Report checkbox.

7. Click Publish. Flash publishes the movie using its default settings, and cre-
ates a size report as a text document.

8. You will now open the size report using a program that can view a text file.
In Windows Explorer/My Computer, navigate to the
Flash MX Level 2 Data folder, and open the Scenes Report.txt document
to view it. Each frame and each item is listed on the report along with its
size. Once again, this can help you locate target items that you can work
with to reduce their size. Close the size report document, and return to
Flash.

Topic 5B
Optimization Factors
It’s extremely important to be aware of the file size of your Flash projects. As the
size of your file increases, its download time increases, as well. Additionally large
files often cause playback interruptions, especially if a large object such as a
complex bitmap or sound occurs in a particular frame.

There are a number of things you can do to keep file size, and resulting down-
load times to a minimum, and to ensure as much as possible smooth playback.

Optimizing Files
Use symbols for every element that appears more than once, and use symbols as
building blocks for more complex symbols.
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Use tweened animations instead of frame-by frame animations. Only use frame-
by-frame animations for effects that can’t be produced using a tween.
Additionally, you can combine tweens with frame-by-frame animations. For
example, when animating a bird flying, only use a frame-by-frame animation for
the flapping of the wings. Use a motion tween to have the bird move across the
Stage.

Use movie clips instead of graphic symbols for animation. Limit the area of
change in each keyframe, having the changing contents in each keyframe isolated
to as small an area as possible.

Avoid animating bitmap elements. If you need to animate, try tracing the bitmap
so it is a vector shape. Reserve bitmap images as background or static elements.

When adding sounds to your projects use MP3, the smallest sound format, when-
ever possible.

Optimizing Objects
Group elements as much as possible.

Use layers to separate elements that change over the course of the animation from
those that do not. Do not put multiple animations in the same layer.

Use the Modify→Curves→Optimize command to minimize the number of sepa-
rate segments and points that identifies a vector shape.

Limit the number of special line styles. Solid lines require less memory. In addi-
tion, lines you create with the Pencil tool produce smaller files sizes than lines
created with brush strokes.

Limit the number of fonts and font styles, and avoid using embedded fonts.
Remember that you can break apart text and treat it as vector objects. If you do
embed fonts, select only the characters you are actually using in the movie
instead of including the entire font.

Optimizing Colors
Use the Color menu in the Property Inspector to create many instances of a single
symbol in different colors instead of creating separate symbols only to change the
color.

Use the Color Mixer to match the color palette of the movie to a browser-specific
palette.

Topic 5C
Exporting and Publishing Movies
In order for your audience to be able to view your Flash movie, you must convert
your native Flash file into a file type that your audience can view. The two ways
to do this in Flash is to either export your movie or publish it. While both meth-
ods allow you to create the same types of files, you choose whether to export or
publish generally based on your workflow.
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Exporting vs Publishing
When you export a movie, the resulting file stands alone. When you publish a
movie, the resulting file is usually combined with an HTML page that includes
the exported file. Because publishing integrates your movie with an HTML page,
you have additional distribution options for your movie beyond those available
when you export. For example, publishing a movie lets you generate a page that
not only contains the movie, but also contains code to check whether the viewer
has the Flash Player installed, and to play an alternate version of the movie that
doesn’t require the Flash Player.

Publishing a Movie
When you publish a Flash movie, you need to follow to main steps. First, you
use the Publish Settings command to select publishing file formats and file format
settings. Next you publish the Flash document using the Publish command.

The options you choose in the Publish Settings dialog box control the files that
the Publish command creates. Using the Formats tab in the Publish Settings dia-
log box, you can have Flash publish the Flash movie file (SWF), the companion
HTML file, or alternate images in a variety of formats that appear automatically
when the Flash Player is not available (GIF, JPEG, PNG, and QuickTime).

You can also have Flash create stand-alone projector files for both Windows and
Macintosh systems, and QuickTime videos from Flash movies.

You will now choose the export formats that you want Flash to generate when
you publish the Scenes movie.

TASK 5C-1:
Selecting Output Formats

1. When you prepare to publish a Flash movie, you should first save the Flash
file in the folder where you want the published files to appear. Flash auto-
matically places the published files in the same folder as the original Flash
movie. You want the published files to appear in the Website folder, you will
first save the file there. Choose File→Save As. Save the Scenes.fla file
inside the Website folder.

2. Choose File→Publish Settings. The Publish Setting dialog box appears.
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3. You want Flash to create both the Flash (SWF) file, along with the compan-
ion HTML file. Click the Formats tab, if necessary. Make sure that the
Flash and HTML checkboxes are checked.

Next, you will rename the files you are going to have Flash publish. By
default, Flash names the files it will export using the same name as the Flash
movie, simply changing the file extension. In this case, because the file is
named Scenes, each of the file names use that same name. However, you
should name all files that will be used on the Web using lowercase
characters.

4. Uncheck the Use Default Names checkbox. You can now rename the files.

5. Type scenes.swfin the Flash file name field.

6. Type scenes.htmlin the HTML file name field.

At this point, if you clicked Publish, Flash would generate the SWF and
HTML files. If you clicked OK, Flash would save the publish settings, asso-
ciating them with the file, but would not yet generate the exported files.

You can enter a path with the
filename to specify where
you want to publish the file,
if you want it to be different
than the default location. You
can set a different path for
each file format (for example,
if you want to publish the
Flash SWF file in one
location and the HTML file in
another location). In
Windows, use backslashes
(\) to specify the directory-
folder-file hierarchy. On the
Macintosh, use colons (:).
Specify the drive name for an
absolute path. In Windows,
use ..\ to indicate the path to
the hard drive.
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Flash Movie Publish Settings
When you publish a Flash movie, the Flash tab in the Publish Settings dialog box
allows you to set the properties of the exported SWF file.

The Version drop-down list allows you to select the version of the Flash Player
that you will output the movie for. If you select Flash Player 6, the viewer may
need that version of the Flash Player installed to view the movie. Many times, it
may be better to select an earlier version unless there are Flash 6–specific fea-
tures that you need for the movie.

The Load order drop-down list allows you to set the order in which Flash loads a
movie’s layers for displaying the first frame of your movie: The Bottom Up
option has the bottom layer load first, and the Top Down option has the top layer
load first.

Checking the Generate Size Report checkbox will have Flash generate a report
listing the amount of data in the final Flash movie by file.

Checking the Protect from Import checkbox prevents others from importing the
Flash movie and converting it back into a Flash (FLA) document.

When you select the Flash Player 6 option in the Version drop-down list, the
Compress Movie checkbox appears. The Compress Movie option automatically
compresses the Flash movie to reduce file size and download time. This option is
on by default and is most beneficial when a file has a lot of text or ActionScript.
A compressed file only plays in Flash Player 6.

Flash automatically uses JPEG compression to reduce the size of bitmap images
in your exported file. To control bitmap compression, you adjust the JPEG Qual-
ity slider or enter a value. Dragging the slider further to the left reduces the
image quality, but produces smaller files. Higher image quality produces larger
files. You often need to experiment to find the best value.

To set the sample rate and compression for all stream sounds or event sounds in
the movie, click the Set button next to Audio Stream or Audio Event and choose
options for Compression, Bit Rate, and Quality in the Sound Settings dialog box.

If you check the Override Sound Settings checkbox, you can override settings for
individual sounds selected in the Sound section of the Property Inspector. If you
don’t select the Select Override Sound Settings option, Flash scans all stream
sounds in the movie (including sounds in imported video) and publishes all
stream sounds at the highest individual setting. This can increase file size, if one
or more stream sounds has a high export setting.
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TASK 5C-2:
Choosing Publish Settings for a Flash Movie

1. Click the Flash tab in the Publish Settings dialog box to view the Flash
settings.

2. Check the Generate Size Report checkbox, if necessary, to generate a
size report.

3. Check the Protect from Import checkbox.

4. You will set the quality for event sounds. Click Set next to the Event
Audio setting. The Sound settings dialog box appears.

5. You will reduce the sound’s bit rate to half of its original. Choose 8 kbps
from the Bit Rate drop-down list

Click OK. You return to the Publish Settings dialog box.

HTML Publish Settings
In order to play a Flash movie in a Web browser, you need to place it in an
HTML document that activates the movie and specifies browser settings. While
you can use an external Web page editor to build an HTML page and embed a
SWF file, the HTML option in the Publish Settings dialog box generates an
HTML document automatically using the parameters selected in the HTML tab.
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Template Settings
The Template drop-down list allows you to select an HTML template that is used
to generate the companion HTML page. You can click the Info button to the right
of the Template drop-down list to view a description of the selected template.

Dimensions Settings
You use the Dimensions drop-down list to select a dimensions option for the
Flash movie within the HTML page. The Match Movie option uses the size of
the movie you specified in the Document Settings dialog box. If you select the
Pixels or Percent option, you can set the values of the width and height
attributes in the <object> and <embed> tags in the HTML page.

Playback Settings
You can use the Playback options to control how the movie plays within the
browser window. The Paused at Start option pauses the movie until a user clicks
a button in the movie or chooses Play from the shortcut menu. By default, the
option is deselected and the movie begins to play as soon as it is loaded.

The Loop option repeats the movie when it reaches the last frame. You should
deselect this option to stop the movie when it reaches the last frame.

The Display Menu option displays a shortcut menu when users right-click (Win-
dows) or [Ctrl]-click (Macintosh) the movie. If you deselect this option, only
About Flash appears in the shortcut menu. By default, this option is selected.

The Device Font option works for Windows machines to substitute anti-aliased
(smooth-edged) system fonts for fonts not installed on the user’s system. Using
device fonts increases the legibility of type at small sizes and can decrease the
movie’s file size. This option only affects movies containing static text (text that
you created when authoring a movie and that does not change when the movie is
displayed) set to display with device fonts.

Quality Settings
The Quality setting determines the trade-off between processing time and apply-
ing anti-aliasing to smooth each frame before it is displayed on the viewer’s
screen, as follows. The Low setting does not use anti-aliasing, and is the fastest
option.

The Auto Low option makes speed a priority but improves appearance whenever
possible. With the Auto Low option, playback of the movie begins with anti-
aliasing turned off. If the Flash Player detects that the processor can handle it,
anti-aliasing is turned on.

The Auto High option emphasizes playback speed and appearance equally at first
but sacrifices appearance for playback speed if necessary. Playback begins with
anti-aliasing turned on. If the actual frame rate drops below the specified frame
rate, anti-aliasing is turned off to improve playback speed. Use this setting to
emulate the View→Antialias setting in Flash.

The Medium applies some anti-aliasing, but does not smooth bitmaps. It produces
a better quality than the Low setting, but lower quality than the High setting.

The default Height setting favors appearance over playback speed and always
uses anti-aliasing. If the movie does not contain animation, bitmaps are
smoothed; if the movie has animation, bitmaps are not smoothed.
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The Best setting provides the best display quality and does not consider playback
speed at all. All output is anti-aliased and bitmaps are always smoothed.

Window Mode Settings
The Window Mode setting for transparency, positioning, and layering only works
for the Windows version of Internet Explorer 4.0 or higher with the Flash
ActiveX control. Therefore, unless your primary audience is using a Windows
machine with a later version of Explorer installed, it might not be best to design
your movies in such a way that the options in the Window Mode setting are
critical.

HTML Alignment Settings
The HTML Alignment settings position the Flash movie window within the
browser window. The Default setting centers the movie in the browser window
and crops the edges of the movie if the browser window is smaller than the
movie.

The Left, Right, Top or Bottom setting aligns movies along the corresponding
edge of the browser window and crops the remaining three sides of the movie as
needed.

Scale Settings
The Scale settings allow you to place the movie within specified boundaries if
you’ve changed the movie’s original width and height. The Scale option sets the
scale parameter in the <object> and <embed> tags.

The Default (Show All) setting displays the entire movie in the specified area
without distortion while maintaining the original aspect ratio of the movies. Bor-
ders may appear on two sides of the movie.

The No Border setting scales the movie to fill the specified area and keeps the
movie’s original aspect ratio without distortion, cropping if needed.

The Exact Fit setting displays the entire movie in the specified area without pre-
serving the original aspect ratio, which may cause distortion of the movie.

The No Scale setting prevents the movie from scaling when the Flash Player win-
dow is resized.

Flash Alignment Settings
The Flash Alignment settings control how the movie is placed within the movie
window and how it is cropped, if necessary. This option sets the salign param-
eter of the <object> and <embed> tags. For Horizontal alignment, choose
Left, Center, or Right. For Vertical alignment, choose Top, Center, or Bottom.

The Show Warning Messages option displays error messages if tag settings
conflict.
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TASK 5C-3:
Choosing HTML Settings for a Flash Movie

1. Click the HTML tab in the Publish Settings dialog box.

2. Choose Detect for Flash 6 from the Template drop-down list, and click
Info. The description the template appears.

3. You will now need to create an alternate image file that the template will
display if the Flash 6 Player is not detected.Click the Formats tab, and
check the JPEG image checkbox. Name the JPEG image scenes.jpg.
Click the HTML tab once again.

4. You do not want the movie to loop. Uncheck the Loop checkbox.

You have completed the Publish settings.

5. Click OK. The Publish settings are retained with the document.
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6. Choose File→Publish. Flash publishes all of the files you specified.

7. View the scenes.html page inside the Website folder inside the
Flash MX Level 2 Data folder in your Web browser.

Summary
In this lesson, you learned how to test a movie to determine its download
performance and pinpoint potential playback problems. You also learned
numerous ways to reduce the size of your files to minimize download time.
Finally, you worked with a number of Publish settings to prepare your
native Flash files for viewing by your audience.

Lesson Review
5A In order to view the movie as it would look as if it were downloading,

what do you need to do?

You need to choose the View→Show Streaming command.

5B You should put all animations in the same layer to reduce file size.

False. Placing multiple animations in the same layer increases file size and
reduces performance.

5C If you want to name a published file using a different name than the
Flash file, what do you need to do?

You need to uncheck the Use Default Names checkbox in the Formats tab in
the Publish settings dialog box.
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button symbol
A symbol that contains four frames allow-
ing you to create buttons with visible
changes as the user interacts with them.

graphic symbol
A symbol best used for static images and
animations that are dependent on the main
movie Timeline.

instance
A copy of a symbol, which doesn’t add to
file size and is linked to its parent symbol.

movie clip symbol
A symbol best used for animations that are
independent of the main movie Timeline.

symbol
A “building block” of Flash content. Sym-
bols are the master objects within a Flash
movie. The three types are graphic, movie
clip, and button symbols.

GLOSSARY
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A
animated button states, 22-24

B
button events, 47-52

button symbols, 3

creating, 19-22

D
Document Library, 25-27

download performance, 76-78

E
expanding menus, 59-62

exporting movies, 80

external movies

loading, 42-45

G
graphic symbols, 2, 4-8

I
instances, 3

creating, 24-25

L
labels

adding labels to a Timeline, 37-38

M
movie clip symbols, 3

combining, 11-14

creating, 8-11

nesting, 17-19

O
optimizing

colors, 79

files, 78

objects, 79

P
playback controls, 40

preloaders

creating, 63-66

publishing movies, 80

dimensions settings, 84

Flash Alignment settings, 85

Flash settings, 82-83

HTML Alignment settings, 85

HTML publish settings, 83-87

playback settings, 84

quality settings, 84

scale settings, 85

template settings, 84

window mode settings, 85

R
remote rollovers, 52-58

S
scenes

creating, 36-37

switching scenes, 40-42

sounds

button states, 69-70

controlling, 70-72

editing, 72-74

event sounds, 70-72

importing, 68-69

streaming sounds, 70-72

Symbol Library, 25-27

symbols, 2

button symbols, 3

duplicating, 27-30

graphic symbols, 2, 4-8

instances, 3

movie clip symbols, 3, 8-11

swapping, 30-33

W
Web navigation controls, 45-47
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